summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJohan Brandhorst2021-10-04 11:35:02 -0400
committerJohan Brandhorst2021-10-04 11:35:02 -0400
commit97b627f26391ce79ae8cf5fc0dcfa41a2b15a706 (patch)
tree8ad3e3c8fe540eae36a149a645d61f614afe4f29 /PKGBUILD
parenta6f30348f4042a285cd99b6900727bccb8abf32f (diff)
downloadaur-97b627f26391ce79ae8cf5fc0dcfa41a2b15a706.tar.gz
Update to v1.0.0-rc3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 9 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bbcf434ddbc3..c7473f214158 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,28 @@
# Maintainer: Johan Brandhorst <jbrandhorst@buf.build>
# Contributor: Alexander Menzhinsky <amenzhinsky@gmail.com>
pkgname=buf
-pkgver=1.0.0rc1
+pkgver=1.0.0rc3
pkgrel=1
pkgdesc="A new way of working with Protocol Buffers"
arch=("any")
url="https://buf.build"
license=('Apache')
makedepends=('go')
-source=("https://github.com/bufbuild/buf/archive/v1.0.0-rc1.tar.gz")
+source=("https://github.com/bufbuild/buf/archive/v1.0.0-rc3.tar.gz")
build() {
- cd ${pkgname}-1.0.0-rc1
+ cd ${pkgname}-1.0.0-rc3
go build -trimpath -buildmode=pie -mod=readonly -modcacherw -o . ./cmd/{buf,protoc-gen-buf-lint,protoc-gen-buf-breaking}
./buf bash-completion >completion.bash
./buf zsh-completion >completion.zsh
}
package() {
- install -Dm755 "${pkgname}-1.0.0-rc1/buf" "${pkgdir}/usr/bin/buf"
- install -Dm755 "${pkgname}-1.0.0-rc1/protoc-gen-buf-lint" "${pkgdir}/usr/bin/protoc-gen-buf-lint"
- install -Dm755 "${pkgname}-1.0.0-rc1/protoc-gen-buf-breaking" "${pkgdir}/usr/bin/protoc-gen-buf-breaking"
- install -Dm644 "${pkgname}-1.0.0-rc1/completion.bash" "${pkgdir}/etc/bash_completion.d/buf"
- install -Dm644 "${pkgname}-1.0.0-rc1/completion.zsh" "${pkgdir}/usr/share/zsh/site-functions/_buf"
+ install -Dm755 "${pkgname}-1.0.0-rc3/buf" "${pkgdir}/usr/bin/buf"
+ install -Dm755 "${pkgname}-1.0.0-rc3/protoc-gen-buf-lint" "${pkgdir}/usr/bin/protoc-gen-buf-lint"
+ install -Dm755 "${pkgname}-1.0.0-rc3/protoc-gen-buf-breaking" "${pkgdir}/usr/bin/protoc-gen-buf-breaking"
+ install -Dm644 "${pkgname}-1.0.0-rc3/completion.bash" "${pkgdir}/etc/bash_completion.d/buf"
+ install -Dm644 "${pkgname}-1.0.0-rc3/completion.zsh" "${pkgdir}/usr/share/zsh/site-functions/_buf"
}
-sha256sums=('0d0ec20014918ac183c705183b20804e06692bbed6338608674d4591738f32bf')
+sha256sums=('0f438e02634e97352047a6dc6f77cbf6f113842040f78334e4b3bb5bf6603cf7')