summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDoria Keung2022-03-24 22:26:20 -0400
committerDoria Keung2022-03-24 22:26:20 -0400
commit97edba2e7842c428ef0fb9716733c35b5c8dfd22 (patch)
tree1d812359442ef5aafa90508715b9d4630b65de38 /PKGBUILD
parent14a4a9da624f0cf9fdb93683e873f492fb2de11f (diff)
downloadaur-97edba2e7842c428ef0fb9716733c35b5c8dfd22.tar.gz
Update to v1.2.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 11 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6cc0375bc9b0..9d5a460c1cfc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
# Maintainer: Buf <bot@buf.build>
# Contributor: Alexander Menzhinsky <amenzhinsky@gmail.com>
pkgname=buf
-pkgver=1.1.1
+pkgver=1.2.1
pkgrel=1
pkgdesc="A new way of working with Protocol Buffers"
arch=("any")
url="https://buf.build"
license=('Apache')
makedepends=('go')
-source=("https://github.com/bufbuild/buf/archive/v1.1.1.tar.gz")
+source=("https://github.com/bufbuild/buf/archive/v1.2.1.tar.gz")
build() {
- cd ${pkgname}-1.1.1
+ cd ${pkgname}-1.2.1
go build -trimpath -buildmode=pie -mod=readonly -modcacherw -o . ./cmd/{buf,protoc-gen-buf-lint,protoc-gen-buf-breaking}
./buf completion bash >completion.bash
./buf completion zsh >completion.zsh
@@ -21,13 +21,13 @@ build() {
}
package() {
- install -Dm755 "${pkgname}-1.1.1/buf" "${pkgdir}/usr/bin/buf"
- install -Dm755 "${pkgname}-1.1.1/protoc-gen-buf-lint" "${pkgdir}/usr/bin/protoc-gen-buf-lint"
- install -Dm755 "${pkgname}-1.1.1/protoc-gen-buf-breaking" "${pkgdir}/usr/bin/protoc-gen-buf-breaking"
- install -Dm644 "${pkgname}-1.1.1/completion.bash" "${pkgdir}/etc/bash_completion.d/buf"
- install -Dm644 "${pkgname}-1.1.1/completion.zsh" "${pkgdir}/usr/share/zsh/site-functions/_buf"
- install -Dm644 "${pkgname}-1.1.1/completion.fish" "${pkgdir}/usr/share/fish/vendor_completions.d/buf.fish"
- install -Dm644 "${pkgname}-1.1.1/manpages/${pkgname}"* -t "${pkgdir}/usr/share/man/man1/"
+ install -Dm755 "${pkgname}-1.2.1/buf" "${pkgdir}/usr/bin/buf"
+ install -Dm755 "${pkgname}-1.2.1/protoc-gen-buf-lint" "${pkgdir}/usr/bin/protoc-gen-buf-lint"
+ install -Dm755 "${pkgname}-1.2.1/protoc-gen-buf-breaking" "${pkgdir}/usr/bin/protoc-gen-buf-breaking"
+ install -Dm644 "${pkgname}-1.2.1/completion.bash" "${pkgdir}/etc/bash_completion.d/buf"
+ install -Dm644 "${pkgname}-1.2.1/completion.zsh" "${pkgdir}/usr/share/zsh/site-functions/_buf"
+ install -Dm644 "${pkgname}-1.2.1/completion.fish" "${pkgdir}/usr/share/fish/vendor_completions.d/buf.fish"
+ install -Dm644 "${pkgname}-1.2.1/manpages/${pkgname}"* -t "${pkgdir}/usr/share/man/man1/"
}
-sha256sums=('506a98a008a5ddbaaed5dd41ac637d9c3317ffb037ff8414baed64610c59ea80')
+sha256sums=('4e90f2c06d0e485c9c2b702295b0b5c262ec0eb73d0ed058d008b23129d12590')