summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAliaksandr Mianzhynski2020-07-12 12:44:20 +0300
committerAliaksandr Mianzhynski2020-07-12 12:44:20 +0300
commit9a45d1bb70f0744529d7ed72cad353dd6c8b986e (patch)
treeee241ba8a58545a62d6f29b35d95fe03da349551 /PKGBUILD
parent392041ae1defbb5ced9003402f5d60b23794d239 (diff)
downloadaur-9a45d1bb70f0744529d7ed72cad353dd6c8b986e.tar.gz
Bump version to v0.19.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 12 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fb1e402b71e9..6055e9febc38 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: Alexander Menzhinsky <amenzhinsky@gmail.com>
pkgname=buf
-pkgver=0.18.1
+pkgver=0.19.1
pkgrel=1
pkgdesc="A new way of working with Protocol Buffers"
-arch=('i686' 'x86_64' 'armv5tel' 'armv6l' 'armv71')
+arch=("any")
url="https://buf.build"
license=('Apache')
depends=('protobuf')
@@ -11,14 +11,18 @@ makedepends=('go')
source=("https://github.com/bufbuild/buf/archive/v${pkgver}.tar.gz")
build() {
- cd ${pkgname}-${pkgver}
- go build -trimpath -mod=readonly -modcacherw -o . ./cmd/{buf,protoc-gen-buf-check-lint,protoc-gen-buf-check-breaking}
+ cd ${pkgname}-${pkgver}
+ go build -trimpath -buildmode=pie -mod=readonly -modcacherw -o . ./cmd/{buf,protoc-gen-buf-check-lint,protoc-gen-buf-check-breaking}
+ ./buf bash-completion >completion.bash
+ ./buf zsh-completion >completion.zsh
}
package() {
- install -Dm755 "${pkgname}-${pkgver}/buf" "${pkgdir}/usr/bin/buf"
- install -Dm755 "${pkgname}-${pkgver}/protoc-gen-buf-check-lint" "${pkgdir}/usr/bin/protoc-gen-buf-check-lint"
- install -Dm755 "${pkgname}-${pkgver}/protoc-gen-buf-check-breaking" "${pkgdir}/usr/bin/protoc-gen-buf-check-breaking"
+ install -Dm755 "${pkgname}-${pkgver}/buf" "${pkgdir}/usr/bin/buf"
+ install -Dm755 "${pkgname}-${pkgver}/protoc-gen-buf-check-lint" "${pkgdir}/usr/bin/protoc-gen-buf-check-lint"
+ install -Dm755 "${pkgname}-${pkgver}/protoc-gen-buf-check-breaking" "${pkgdir}/usr/bin/protoc-gen-buf-check-breaking"
+ install -Dm644 "${pkgname}-${pkgver}/completion.bash" "${pkgdir}/etc/bash_completion.d/buf"
+ install -Dm644 "${pkgname}-${pkgver}/completion.zsh" "${pkgdir}/usr/share/zsh/site-functions/_buf"
}
-sha256sums=('2cda10542cc0a23e85f4078ebb9ff02a5635a3e573ea6023ce9b37c0e97a1994')
+sha256sums=('41232fc472e19dd728b066f5f0a02a222bebcf6426d24f7b8e90f6939f3deb40')