summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDoria Keung2022-07-27 19:09:05 -0400
committerDoria Keung2022-07-27 19:09:05 -0400
commita46ac5a647e21fa5464248d392314819c3eb584c (patch)
treed1bc1413196425be9e965733ec940507fcc8be1f /PKGBUILD
parentb0b976dcfeefd8f0252a99ad0fe5e2974453f7de (diff)
downloadaur-a46ac5a647e21fa5464248d392314819c3eb584c.tar.gz
Update to v1.7.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 11 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7ba58af54f74..8893e8e37a44 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
# Maintainer: Buf <bot@buf.build>
# Contributor: Alexander Menzhinsky <amenzhinsky@gmail.com>
pkgname=buf
-pkgver=1.6.0
+pkgver=1.7.0
pkgrel=1
pkgdesc="A new way of working with Protocol Buffers"
arch=("any")
url="https://buf.build"
license=('Apache')
makedepends=('go')
-source=("https://github.com/bufbuild/buf/archive/v1.6.0.tar.gz")
+source=("https://github.com/bufbuild/buf/archive/v1.7.0.tar.gz")
build() {
- cd ${pkgname}-1.6.0
+ cd ${pkgname}-1.7.0
go build -trimpath -buildmode=pie -mod=readonly -modcacherw -o . ./cmd/{buf,protoc-gen-buf-lint,protoc-gen-buf-breaking}
./buf completion bash >completion.bash
./buf completion zsh >completion.zsh
@@ -21,13 +21,13 @@ build() {
}
package() {
- install -Dm755 "${pkgname}-1.6.0/buf" "${pkgdir}/usr/bin/buf"
- install -Dm755 "${pkgname}-1.6.0/protoc-gen-buf-lint" "${pkgdir}/usr/bin/protoc-gen-buf-lint"
- install -Dm755 "${pkgname}-1.6.0/protoc-gen-buf-breaking" "${pkgdir}/usr/bin/protoc-gen-buf-breaking"
- install -Dm644 "${pkgname}-1.6.0/completion.bash" "${pkgdir}/etc/bash_completion.d/buf"
- install -Dm644 "${pkgname}-1.6.0/completion.zsh" "${pkgdir}/usr/share/zsh/site-functions/_buf"
- install -Dm644 "${pkgname}-1.6.0/completion.fish" "${pkgdir}/usr/share/fish/vendor_completions.d/buf.fish"
- install -Dm644 "${pkgname}-1.6.0/manpages/${pkgname}"* -t "${pkgdir}/usr/share/man/man1/"
+ install -Dm755 "${pkgname}-1.7.0/buf" "${pkgdir}/usr/bin/buf"
+ install -Dm755 "${pkgname}-1.7.0/protoc-gen-buf-lint" "${pkgdir}/usr/bin/protoc-gen-buf-lint"
+ install -Dm755 "${pkgname}-1.7.0/protoc-gen-buf-breaking" "${pkgdir}/usr/bin/protoc-gen-buf-breaking"
+ install -Dm644 "${pkgname}-1.7.0/completion.bash" "${pkgdir}/etc/bash_completion.d/buf"
+ install -Dm644 "${pkgname}-1.7.0/completion.zsh" "${pkgdir}/usr/share/zsh/site-functions/_buf"
+ install -Dm644 "${pkgname}-1.7.0/completion.fish" "${pkgdir}/usr/share/fish/vendor_completions.d/buf.fish"
+ install -Dm644 "${pkgname}-1.7.0/manpages/${pkgname}"* -t "${pkgdir}/usr/share/man/man1/"
}
-sha256sums=('6743b383ea2833723f7dc3b5f85667dab25bec3990769e980436e09b0c2553c0')
+sha256sums=('090e72d2808b4e3d641259a482931c40e77532fb3062d70c2f9b80f7f6e7e1bd')