summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChih-Hsuan Yen2018-07-16 23:36:32 +0800
committerChih-Hsuan Yen2018-07-16 23:36:32 +0800
commite0120ce31679f55e915869ea50292c8e79904022 (patch)
tree969c5d5d921a9e2de96c3099923985a173ee62b3 /PKGBUILD
parent035ce8f531ca18d781a5c520ecc7936fc1d56ba6 (diff)
downloadaur-e0120ce31679f55e915869ea50292c8e79904022.tar.gz
allow cairosvg2, the one in [community]
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 20 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 598954fca598..efc3807da6f6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,16 +6,19 @@
pkgbase=buildbot-www-git
pkgname=('python-buildbot-www-git' 'python-buildbot-waterfall-view-git'
- 'python-buildbot-console-view-git' 'python-buildbot-grid-view-git' 'python-buildbot-wsgi-dashboards-git'
+ 'python-buildbot-console-view-git' 'python-buildbot-grid-view-git'
+ 'python-buildbot-wsgi-dashboards-git' 'python-buildbot-badges-git'
)
-pkgver=1.2.0.r40.g16dff07ce
+pkgver=1.3.0.r2.g95fc42ba3
pkgrel=1
arch=('any')
url="https://buildbot.net"
license=("GPL")
makedepends=('git' "buildbot-git=$pkgver" "buildbot-pkg-git=$pkgver" 'python-mock' 'npm' 'yarn')
-source=(git+https://github.com/buildbot/buildbot.git)
-sha256sums=('SKIP')
+source=(git+https://github.com/buildbot/buildbot.git
+ cairosvg2.patch)
+sha256sums=('SKIP'
+ 'efb460cb040cfd2438d63df51cc7ffd93444dd9d6e1b172f870f4ffce5bafda8')
pkgver() {
cd buildbot
@@ -25,6 +28,11 @@ pkgver() {
)
}
+prepare() {
+ cd buildbot
+
+ patch -Np1 -i ../cairosvg2.patch
+}
package_python-buildbot-www-git() {
depends=("buildbot-git=$pkgver")
@@ -65,3 +73,11 @@ package_python-buildbot-wsgi-dashboards-git() {
cd buildbot/www/wsgi_dashboards
python setup.py install --root="$pkgdir" --optimize=1
}
+
+package_python-buildbot-badges-git() {
+ depends=("buildbot-git=$pkgver" 'python-klein' 'python-cairosvg' 'python-cairocffi' 'python-jinja')
+ pkgdesc="Buildbot badges"
+
+ cd buildbot/www/badges
+ python setup.py install --root="$pkgdir" --optimize=1
+}