summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRafael Fontenelle2021-05-30 21:05:04 -0300
committerRafael Fontenelle2021-05-30 21:05:04 -0300
commit315b0122fdd2247c19b74c0242577f52e0ee5185 (patch)
treecf1a4c863eb776d76d1b52313ce3873afb4d4854 /PKGBUILD
downloadaur-315b0122fdd2247c19b74c0242577f52e0ee5185.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..125aff56bfa3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Rafael Fontenelle <rafaelff@gnome.org>
+pkgname=buildstream-devel
+pkgver=1.93.6
+pkgrel=1
+pkgdesc="A powerful and flexible software integration toolset"
+arch=('x86_64')
+url="https://buildstream.build"
+license=('LGPL')
+depends=(
+ bubblewrap
+ buildbox-casd
+ python-click
+ python-dateutil
+ python-grpcio
+ python-jinja
+ python-pluginbase
+ python-protobuf
+ python-psutil
+ python-pyroaring
+ python-ruamel-yaml
+ python-ujson
+ # specific host site dependencies
+ git lzip
+)
+
+makedepends=(python-setuptools cython)
+provides=('buildstream')
+conflicts=('buildstream')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/apache/buildstream/archive/refs/tags/$pkgver.tar.gz")
+sha256sums=('377876c169162227c087ebde4f8543c556b894f37d9bc3d8cb23b2d3db707f47')
+
+build() {
+ cd buildstream-$pkgver
+ python setup.py build
+}
+
+package() {
+ cd buildstream-$pkgver
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}