summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRafael Fontenelle2018-06-29 08:11:35 -0300
committerRafael Fontenelle2018-06-29 08:13:02 -0300
commitdbf67b46436f661b6b19720490c1f359652b45d8 (patch)
treeb0e21c64650ab0a6dab89ca9d1b5490eece99e2c /PKGBUILD
parent95c108cc0ceb112e2573d36b5790b1a7be8bd7f2 (diff)
downloadaur-dbf67b46436f661b6b19720490c1f359652b45d8.tar.gz
Add host sites dependencies
Also separate build from package funtions
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 13 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a052a84681f9..54f6f2a59ec2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Rafael Fontenelle <rafaelff@gnome.org>
pkgname=buildstream-git
-pkgver=1.1.2+183+g880e1913
+pkgver=1.1.3+167+g91d87e3c
pkgrel=1
pkgdesc="Framework for modelling build pipelines in a declarative YAML format"
arch=('any')
@@ -8,7 +8,9 @@ url="https://wiki.gnome.org/Projects/BuildStream/"
license=('LGPL')
depends=('bubblewrap' 'ostree' 'python-blessings' 'python-click'
'python-jinja' 'python-gobject' 'python-pluginbase'
- 'python-psutil' 'python-ruamel-yaml')
+ 'python-psutil' 'python-ruamel-yaml'
+ # specific host site dependencies
+ 'bzr' 'git' 'lzip')
makedepends=('python-setuptools' 'git')
provides=('buildstream')
conflicts=('buildstream')
@@ -16,11 +18,16 @@ source=("git+https://gitlab.com/BuildStream/buildstream.git")
md5sums=('SKIP')
pkgver() {
- cd buildstream
- git describe --tags | sed 's/-/+/g'
+ cd buildstream
+ git describe --tags | sed 's/-/+/g'
+}
+
+build() {
+ cd buildstream
+ python setup.py build
}
package() {
- cd buildstream
- python setup.py install --root="$pkgdir/" --optimize=1
+ cd buildstream
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
}