diff options
author | Ayush Agarwal | 2022-07-02 21:56:12 +0530 |
---|---|---|
committer | Ayush Agarwal | 2022-07-02 21:56:12 +0530 |
commit | 96d26f2da6af930297a8fac89c1a827f57a96234 (patch) | |
tree | 2a6302ec96f43610c7670e81513781321226a9d9 /PKGBUILD | |
parent | 652f71ef70ec7b3d4fbcfa42b29be4b30b1650e5 (diff) | |
download | aur-96d26f2da6af930297a8fac89c1a827f57a96234.tar.gz |
release: bump version to 4.7
python-certifi has been removed in favor of ca-certificates
formatted the PKGBUILD with shfmt
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 49 |
1 files changed, 26 insertions, 23 deletions
@@ -1,42 +1,45 @@ -# Maintainer: Ayush Agarwal <ayush at fastmail dot in> +# Maintainer: Ayush Agarwal <ayushnix at fastmail dot com> # Contributor: Ben Oliver <ben at bfoliver dot com> # Contributor: Andy Weidenbaum <archbaum at gmail dot com> # Contributor: John Jenkins <twodopeshaggy at gmail dot com> # Contributor: Julian Paul Dasmarinas <julian.dasma at gmail dot com> pkgname=buku -pkgver=4.6 -pkgrel=2 +pkgver=4.7 +pkgrel=1 pkgdesc="Bookmark manager like a text-based mini-web" arch=('any') url="https://github.com/jarun/buku" license=('GPL') -depends=('python' - 'python-certifi' - 'python-urllib3' - 'python-cryptography' - 'python-beautifulsoup4' - 'python-html5lib') +depends=('ca-certificates' + 'python-beautifulsoup4' + 'python-cryptography' + 'python-html5lib' + 'python-urllib3') makedepends=('python-setuptools') optdepends=('wl-clipboard: to copy text in wayland' - 'wl-clipboard-rs: to copy text in wayland' - 'xsel: to copy text in xorg' - 'xclip: to copy text in xorg') + 'wl-clipboard-rs: to copy text in wayland' + 'xsel: to copy text in xorg' + 'xclip: to copy text in xorg') conflicts=('buku-git') source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz") -sha256sums=('2e1968016d3856184db8ac49cdc92a6c70869f62846185f28c8c60ead0c42888') +sha256sums=('11d0860e66e0eea6c2ce566962ae0f8e34c76dc2317d108a4ae4e5a47097d468') package() { - cd "$pkgname-$pkgver" - export PYTHONHASHSEED=0 - python setup.py install --root="$pkgdir" --prefix=/usr --optimize=1 + cd "$pkgname-$pkgver" 2> /dev/null || { + printf "%s\n" "unable to cd to $pkgname-$pkgver" + exit 1 + } + export PYTHONHASHSEED=0 + python setup.py install --root="$pkgdir" --prefix=/usr --optimize=1 - rm -f "$pkgdir"/usr/bin/bukuserver - rm -rf "$pkgdir"/usr/lib/python3.9/site-packages/bukuserver - gzip -f buku.1 + local site_packages=$(python -c "import site; print(site.getsitepackages()[0])") + rm -f "$pkgdir"/usr/bin/bukuserver + rm -rf "$pkgdir/$site_packages"/bukuserver + gzip -f buku.1 - install -Dm644 auto-completion/fish/buku.fish "${pkgdir}/usr/share/fish/vendor_completions.d/buku.fish" - install -Dm644 auto-completion/bash/buku-completion.bash "${pkgdir}/usr/share/bash-completion/completions/buku" - install -Dm644 auto-completion/zsh/_buku "${pkgdir}/usr/share/zsh/site-functions/_buku" - install -Dm644 buku.1.gz "${pkgdir}/usr/share/man/man1/buku.1.gz" + install -Dm644 auto-completion/fish/buku.fish "${pkgdir}/usr/share/fish/vendor_completions.d/buku.fish" + install -Dm644 auto-completion/bash/buku-completion.bash "${pkgdir}/usr/share/bash-completion/completions/buku" + install -Dm644 auto-completion/zsh/_buku "${pkgdir}/usr/share/zsh/site-functions/_buku" + install -Dm644 buku.1.gz "${pkgdir}/usr/share/man/man1/buku.1.gz" } |