summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMartti Kühne2015-06-13 09:29:11 +0200
committerMartti Kühne2015-06-13 09:29:11 +0200
commit1b984abfe9290abea9cf635836f3c7f08b8efccc (patch)
tree46ae35190753648da3da037bd18a6333f2ccc9d1 /PKGBUILD
downloadaur-bulk77i-git.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..213e43a040f5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: mar77i <mar77i at mar77i dot ch>
+pkgname=bulk77i-git
+_pkgname=bulk77i
+pkgrel=1
+pkgver=v0.2.4.g4b04119
+pkgdesc="mar77i's basic C datatypes collection"
+arch=(x686 x86_64)
+url="https://github.com/mar77i/bulk77i"
+license=('GPL')
+makedepends=('git')
+source=("git+https://github.com/mar77i/bulk77i.git")
+md5sums=(SKIP)
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --tags |sed 's/-/./g'
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+ make
+}
+
+package() {
+ local lpfx="/usr/share/licenses"
+ cd "$srcdir"
+ make -C "$_pkgname" DESTDIR="$pkgdir/" PREFIX=/usr install
+ install -m644 -D "$_pkgname/LICENSE" "$pkgdir/$lpfx/$pkgname/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: