summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJens John2016-06-23 21:00:06 +0900
committerJens John2016-06-23 21:00:06 +0900
commit2d05eaf11a4c401cc95bdf7e35e409653ee48955 (patch)
tree24401eb6280441bf8bea9359fa38cbad94542f83 /PKGBUILD
parente7ff046e03d51e7e4e62d201c0909190b66801aa (diff)
downloadaur-2d05eaf11a4c401cc95bdf7e35e409653ee48955.tar.gz
Reflect upstream changes
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 6 insertions, 22 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5a3c7f683a33..5036af41f5cb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,45 +1,29 @@
# Maintainer: 2ion <dev@2ion.de>
pkgname=bunsen-utilities-git
-pkgver=r81.dc043ef
+pkgver=r141.e1caa5d
pkgrel=1
pkgdesc="Collection of utility scripts"
arch=('any')
url="https://github.com/BunsenLabs/bunsen-utilities"
license=('GPL3')
-depends=('python' 'pygtk' 'python-xlib' 'python-lxml')
+depends=('bunsen-common' 'python' 'python2' 'pygtk' 'python-xlib' 'python-lxml' 'yad')
optdepends=(\
'upower: Required for bl-exit' \
'zenity: Required bl-conkyzen and bl-tint2edit')
makedepends=('git')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-source=(\
- "${pkgname%-git}::git+https://github.com/BunsenLabs/bunsen-utilities.git#branch=master" \
- 'https://raw.githubusercontent.com/Unia/bunsen-utilities/master/bl-aerosnap' \
- 'https://raw.githubusercontent.com/Unia/bunsen-utilities/rewrite-hotcorners/bl-hotcorners' \
- 'bl-hotcorners-syntax.patch')
-md5sums=(\
- 'SKIP' \
- 'SKIP' \
- 'SKIP' \
- '2cb280313bd01a391437e4b960142d80')
+source=("${pkgname%-git}::git+https://github.com/BunsenLabs/bunsen-utilities.git#branch=master")
+md5sums=(SKIP)
pkgver() {
cd "$srcdir/${pkgname%-git}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-prepare() {
- cd "$srcdir/${pkgname%-git}"
- cd "$srcdir" ; cd ..
- patch bl-hotcorners bl-hotcorners-syntax.patch
-}
-
package() {
cd "$srcdir/${pkgname%-git}"
install -d "${pkgdir}/usr/bin"
- install -t "${pkgdir}/usr/bin" bl-*
- cd "$srcdir"
- install -t "${pkgdir}/usr/bin" bl-aerosnap
- install -t "${pkgdir}/usr/bin" bl-hotcorners
+ install -t "${pkgdir}/usr/bin" bin/bl-*
+ install -Dm644 bl-exitrc "${pkgdir}/etc/bl-exit/bl-exitrc"
}