summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGordian Edenhofer2016-05-12 15:15:29 +0200
committerGordian Edenhofer2016-05-12 15:15:29 +0200
commit99a641e90391d7b773946ad2b331a2bb7274b297 (patch)
tree4379e8e80bc63b099bd2d77c2afec29f5a8d76c0 /PKGBUILD
parentfdf7b94a366437c0cb2ad28fa6b55cacb655cc10 (diff)
downloadaur-99a641e90391d7b773946ad2b331a2bb7274b297.tar.gz
upgpkg: bup-git 1364.cad3c11-3
Use configure to set python to python2 instead of manipulating the build files with sed. The functionality was only recently introduced but already works at the master branch.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 5 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4c1dbb7d0aff..54d210d8f188 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=bup-git
pkgver=1364.cad3c11
-pkgrel=2
+pkgrel=3
pkgdesc='Efficient file backup system based on the git packfile format'
arch=('i686' 'x86_64')
url='https://bup.github.io/'
@@ -26,25 +26,17 @@ pkgver() {
prepare() {
cd "${srcdir}/${pkgname}"
- # Fixing numerous false invocations since python2 is needed
- find . -type f -exec sed -i -e '1s/env python\b/env python2/' {} +
- sed -i -e 's/find_prog python\b/find_prog python2/' \
- -e 's/MF_PATH_INCLUDE PYTHON python\b/MF_PATH_INCLUDE PYTHON python2/' \
- config/configure
- sed -i -e 's/PYTHON=python\b/PYTHON=python2/' -e '/docs-available/d' Makefile
- sed -i -e 's/python\b -c/python2 -c/' t/{lib,test-meta,test-ls}.sh
-
- # Make test suite happy
- #git config --global user.email "bob@zombo.com"
+ # Configure the program to use python2 everywhere
+ PYTHON=/usr/bin/python2 ./configure
}
build() {
make -C "${srcdir}/${pkgname}"
}
-# Disabled in favor of increased speed
+# Disabled in favor of increased speed - it should pass if run
#check() {
-# make -C "${srcdir}/${pkgname}" test -j1
+# make -C "${srcdir}/${pkgname}" test
#}
package() {