summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGreyson Christoforo2021-03-05 18:20:17 +0000
committerGreyson Christoforo2021-03-05 18:20:17 +0000
commit5786c49ec30b3d45b36bc81283c069621ed9dd6f (patch)
treef3db91d6fe5ef0affab0a2ce81fe7820db2f58a9 /PKGBUILD
parent703e233c2f7f4b5a833f1469a0a65c1fa051afd3 (diff)
downloadaur-bus-pirate.tar.gz
add usage note
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f8e94ff2dcff..346e5d7315f9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,9 +5,9 @@ pkgver=2.3.8
pkgrel=5
pkgdesc="Software and firmware for an open source hacker multi-tool that talks to electronic stuff"
url="http://dangerousprototypes.com/docs/Bus_Pirate"
-arch=('any')
+arch=('x86_64')
license=('CC-0' 'GPL')
-depends=('qt5-base' 'python2')
+depends=('qt5-base' 'python2' 'python-pyserial')
install=$pkgname.install
source=("https://github.com/greyltc/Bus_Pirate/archive/v${pkgver}.tar.gz" "25_busBirate.rules")
@@ -53,6 +53,9 @@ package() {
ln -s /opt/${pkgname}/package/BPv4-firmware/pirate-loader-v4-source/pirate-loader_lnx ${pkgdir}/usr/bin/pirate-loader
ln -s /opt/${pkgname}/scripts/BusPirateGUI/BusPirateGui ${pkgdir}/usr/bin/bus-pirate-gui
ln -s /opt/${pkgname}/scripts/powertools/SPISniffer/linux-version/spisniffer ${pkgdir}/usr/bin/spi-sniffer
+
+ msg2 "Get into your bus pirate's terminal interface like this:"
+ msg2 "python -m serial.tools.miniterm /dev/bus_pirate1 115200 --eol LF"
}
# vim:set ts=2 sw=2 et: