summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCaleb Maclennan2020-10-21 12:37:51 +0300
committerCaleb Maclennan2020-10-21 12:37:51 +0300
commita3af34f4f5f057444227e605d27cc1da8350dffc (patch)
treee238a68aea0fa9f79f515ffa40bda198a3fc0809 /PKGBUILD
downloadaur-butler-font.tar.gz
Initial upload: butler-font 1.000-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..94e301a99e94
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
+
+_name=butler
+pkgbase=$_name-font
+pkgname=(otf-$_name otf-$_name-stencil)
+pkgver=1.000
+pkgrel=1
+pkgdesc='A serif font family inspired by Dala Floda & the Bodoni family'
+arch=('any')
+url="http://fabiandesmet.com/portfolio/$pkgbase"
+license=('custom')
+source=("https://fabiandesmet.com/wp-content/uploads/Butler_and_ButlerStencil.zip")
+sha256sums=('ebf56a01103f100420cb4e54accd0ab839d064dbae462d72294212a5e5d9a798')
+
+package_otf-butler() {
+ cd ${_name^}
+ install -Dm644 -t "$pkgdir/usr/share/fonts/OTF/" *.otf
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname/" ../Butler_ButlerStencil_FontLicense_v1_1.pdf
+}
+
+package_otf-butler-stencil() {
+ cd ${_name^}_Stencil
+ install -Dm644 -t "$pkgdir/usr/share/fonts/OTF/" *.otf
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname/" ../Butler_ButlerStencil_FontLicense_v1_1.pdf
+}