summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJosef Miegl2019-02-07 17:46:21 +0100
committerJosef Miegl2019-02-07 17:46:21 +0100
commit201d2c0256537f8841144f628fd6373fccd91f9f (patch)
tree8a37c35324226be0795424020fcf8a206f287b69 /PKGBUILD
parentdd214fd39179d807eb1e965e6a71547e6aecc307 (diff)
downloadaur-201d2c0256537f8841144f628fd6373fccd91f9f.tar.gz
style
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD62
1 files changed, 32 insertions, 30 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e7b768d122b6..2a2c9778845a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,43 +5,45 @@
pkgname=butt
pkgver=0.1.17
pkgrel=1
-pkgdesc="butt (broadcast using this tool) is an easy to use, multi OS streaming tool"
-arch=('i686' 'x86_64' 'armv7h')
+pkgdesc="Easy to use, multi OS streaming tool"
+arch=('i686' 'x86_64' 'aarch64' 'armv7h')
license=('GPL2')
url="http://butt.sourceforge.net/"
depends=('fltk' 'libpng12' 'portaudio' 'libfdk-aac' 'libvorbis' 'libogg' 'lame' 'flac' 'opus' 'libsamplerate')
-source=("http://sourceforge.net/projects/${pkgname}/files/${pkgname}/${pkgname}-${pkgver}/${pkgname}-${pkgver}.tar.gz")
+source=(${pkgname}-${pkgver}.tar.gz::"http://sourceforge.net/projects/${pkgname}/files/${pkgname}/${pkgname}-${pkgver}/${pkgname}-${pkgver}.tar.gz")
sha256sums=('afe9596b1d9ef38d2fde1f3255e5a3a12b206c73c8e6601e37cccb07e67ae33d')
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- ./configure --prefix=/usr
- make
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr
+ make
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- make DESTDIR="${pkgdir}" install
-
- # Desktop file
- install -Dm644 "usr/share/applications/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
-
- # Icons
- for size in 16 22 24 32 48 64 96 128 256 512; do
- format="${size}x${size}"
- install -Dm644 "icons/icon_${format}.png" "${pkgdir}/usr/share/icons/hicolor/${format}/apps/${pkgname}.png"
- done
-
- install -Dm644 "icons/icon_scalable.svg" "${pkgdir}/usr/share/icons/hicolor/scalable/apps/${pkgname}.svg"
-
- # Documentation
- for doc in AUTHORS ChangeLog KNOWN_BUGS NEWS README THANKS; do
- install -Dm644 "${doc}" "${pkgdir}/usr/share/doc/${pkgname}/${doc}"
- done
-
- # Pixmaps
- for file in usr/share/pixmaps/"${pkgname}"*; do
- filename=`basename "${file}"`
- install -Dm644 "${file}" "${pkgdir}/usr/share/pixmaps/${filename}"
- done
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+
+ # Desktop file
+ install -Dm644 "usr/share/applications/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+
+ # Icons
+ for size in 16 22 24 32 48 64 96 128 256 512; do
+ format="${size}x${size}"
+ install -Dm644 "icons/icon_${format}.png" "${pkgdir}/usr/share/icons/hicolor/${format}/apps/${pkgname}.png"
+ done
+
+ install -Dm644 "icons/icon_scalable.svg" "${pkgdir}/usr/share/icons/hicolor/scalable/apps/${pkgname}.svg"
+
+ # Documentation
+ for doc in AUTHORS ChangeLog KNOWN_BUGS NEWS README THANKS; do
+ install -Dm644 "${doc}" "${pkgdir}/usr/share/doc/${pkgname}/${doc}"
+ done
+
+ # Pixmaps
+ for file in usr/share/pixmaps/"${pkgname}"*; do
+ filename=`basename "${file}"`
+ install -Dm644 "${file}" "${pkgdir}/usr/share/pixmaps/${filename}"
+ done
}
+
+# vim:set ts=2 sw=2 et: