summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJosef Miegl2018-07-17 22:47:50 +0200
committerJosef Miegl2018-07-17 22:47:50 +0200
commit83666e3956408a0da8c674a5a50610698cf361c7 (patch)
tree714a2e28cf78e9747fbc53b731c090bee0de9ba8 /PKGBUILD
parent92ac1bebdfb10095c3f92618812f71a45427836d (diff)
downloadaur-83666e3956408a0da8c674a5a50610698cf361c7.tar.gz
install desktop file, icons, docs and pixmaps
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 24 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c3da29d5685d..1aa6e182d9bb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=butt
pkgver=0.1.16
-pkgrel=2
+pkgrel=3
pkgdesc="butt (broadcast using this tool) is an easy to use, multi OS streaming tool"
arch=('i686' 'x86_64')
license=('GPL2')
@@ -31,4 +31,27 @@ build() {
package() {
cd "$pkgname-$pkgver"
make DESTDIR="$pkgdir/" install
+
+ # Desktop file
+ # Category "Sound" is invalid, reaplce it with "AudioVideo;Audio"
+ desktop-file-install --remove-category="Sound" --add-category="AudioVideo;Audio" --dir="$pkgdir/usr/share/applications" "icons/$pkgname.desktop"
+
+ # Icons
+ for size in 16 22 24 32 48 64 96 128 256 512; do
+ format="${size}x${size}"
+ install -D -m644 "icons/icon_${format}.png" "$pkgdir/usr/share/icons/hicolor/${format}/apps/$pkgname.png"
+ done
+
+ install -D -m644 "icons/icon_scalable.svg" "$pkgdir/usr/share/icons/hicolor/scalable/apps/$pkgname.svg"
+
+ # Documentation
+ for doc in AUTHORS ChangeLog KNOWN_BUGS NEWS README THANKS; do
+ install -D -m644 "${doc}" "$pkgdir/usr/share/doc/$pkgname/${doc}"
+ done
+
+ # Pixmaps
+ for file in usr/share/pixmaps/"$pkgname"*; do
+ filename=`basename "${file}"`
+ install -D -m644 "${file}" "$pkgdir/usr/share/pixmaps/${filename}"
+ done
}