summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJosef Miegl2018-07-17 17:01:30 +0200
committerJosef Miegl2018-07-17 17:01:30 +0200
commitc53637f7cfafa083a8a25c9d78a754fc59a34ed1 (patch)
tree46d2a7cf155a531a7ad3100d4b0f678f0ff4ee45 /PKGBUILD
parent9e7d6c94191529b33caf6a64994b3171d3d91d23 (diff)
downloadaur-c53637f7cfafa083a8a25c9d78a754fc59a34ed1.tar.gz
butt 0.1.16
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 16 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 943b974a27c5..e2935b06e09f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,26 @@
-# Maintainer: goll <adrian.goll+aur[at]gmail>
+# Maintainer: Josef Miegl <josef@miegl.cz>
+# Contributor: goll <adrian.goll+aur[at]gmail>
# Contributor: Kosava <kosava@gmail.com>
pkgname=butt
-pkgver=0.1.14
+pkgver=0.1.16
pkgrel=1
pkgdesc="butt (broadcast using this tool) is an easy to use, multi OS streaming tool"
arch=('i686' 'x86_64')
-license=("GPL2")
+license=('GPL2')
url="http://butt.sourceforge.net/"
-depends=('fltk' 'libpng12')
-optdepends=('icecast' 'shoutcast')
-source=("http://sourceforge.net/projects/$pkgname/files/$pkgname/$pkgname-$pkgver/$pkgname-$pkgver.tar.gz")
-sha1sums=('f1dfba4f14f5584ef56790734754b4db8fa005a1')
+depends=('fltk' 'libpng12' 'portaudio' 'libfdk-aac')
+optdepends=('icecast')
+source=("http://sourceforge.net/projects/$pkgname/files/$pkgname/$pkgname-$pkgver/$pkgname-$pkgver.tar.gz"
+ "butt-gcc6.patch")
+sha256sums=('50feef4fe051484a2eb897b0175cf5f7b3f94f395c34c84d917b1a41c6fb6897'
+ 'a420be932c97ee949c18428230d8f3a1aabada07c06cd8109757aef68910b5ab')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ patch -Np1 -i "$srcdir/butt-gcc6.patch"
+}
+
build() {
cd "$pkgname-$pkgver"