summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsum012017-12-29 17:16:23 -0500
committersum012017-12-29 17:16:23 -0500
commitf96b0836c25db8cc3f3dc4c2f9a6ef1918065efa (patch)
treefad2bd97b21b0cd0f4197262be11aab8088a80dc /PKGBUILD
parentff8e4ba6cf00b7d8fadc7b187287cd3d5ef21cc1 (diff)
downloadaur-f96b0836c25db8cc3f3dc4c2f9a6ef1918065efa.tar.gz
Fix build with a lazy patch
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1112993bf386..15ff0c84f707 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: j1simon
pkgname=buttercup-desktop
pkgver=0.25.2
-pkgrel=2
+pkgrel=3
pkgdesc='Javascript Password Vault - Multi-Platform Desktop Application'
arch=('i686' 'x86_64')
url="https://github.com/buttercup/buttercup-desktop"
@@ -10,10 +10,14 @@ license=('GPL3')
depends=('gtk2' 'gconf' 'libxtst' 'alsa-lib' 'libxss' 'nss')
makedepends=('npm' 'sed')
source=("https://github.com/buttercup/buttercup-desktop/archive/v$pkgver.tar.gz"
- "buttercup-desktop.desktop")
+ "buttercup-desktop.desktop"
+ "fix_arch.patch")
sha512sums=('d549e74a0cfb564b29c4ced9c42e7c52446277438fe805f856d61f031d01acd7aacd48f71c00c0b4ed6ed2d7ef8d6f19d264188f9b8758f098df15b2880978bd'
- '7ecea9e3e00b3b967d669ddb1777f194c5a4ae3e7e6bd941831b9a594ddb5215d264e513d25203268a1de1fa684a2a9ec4642f32233c403b5e425ecf9e7ae988')
+ '7ecea9e3e00b3b967d669ddb1777f194c5a4ae3e7e6bd941831b9a594ddb5215d264e513d25203268a1de1fa684a2a9ec4642f32233c403b5e425ecf9e7ae988'
+ 'dd9595ea6d6e458d5c7881d49ca5a79b73e9214ea981042f0f76f4c754a93a9df39ccf029d5e01a88b17f95f01e18533964fd7ea16e3810c228b72003d4e110a')
prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+ patch -Np1 -i "$srcdir/fix_arch.patch"
sed -i '/"rpm",/d' "$srcdir/$pkgname-$pkgver/package.json"
sed -i '/"AppImage",/d' "$srcdir/$pkgname-$pkgver/package.json"
sed -i 's/"deb"/"dir"/' "$srcdir/$pkgname-$pkgver/package.json"