summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authortimetoplatypus2019-09-07 10:31:32 -0400
committertimetoplatypus2019-09-07 10:31:32 -0400
commit282342a22b409eb29f6f3434cd22bb9e7c65d628 (patch)
tree17042c5e29f7b120df3b6cd6ea08ac0f75cf1f5b /PKGBUILD
downloadaur-282342a22b409eb29f6f3434cd22bb9e7c65d628.tar.gz
Base
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD47
1 files changed, 47 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ba05dbabf284
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: timetoplatypus <timetoplatypus@protonmail.com>
+pkgname=bytewalk
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="A firmware extraction tool & binwalk fork"
+arch=("any")
+url="https://gitlab.com/bytesweep/bytewalk"
+license=("MIT")
+source=("https://gitlab.com/bytesweep/$pkgname/-/archive/v$pkgver/$pkgname-v$pkgver.tar.gz")
+md5sums=("b8a8709b05fb20eea30b21c7db364d24")
+depends=("python")
+optdepends=(
+ 'python-pyqtgraph: graph and visualization support'
+ 'python-opengl: binviz module support'
+ 'python-capstone: disassembly support'
+ 'arj: ARJ decompression support'
+ 'cabextract: CAB archive support'
+ 'cpio: CPIO archvie support'
+ 'gzip: GZIP decompression support'
+ 'mtd-utils: JFFS filesystem support'
+ 'p7zip: ZIP, LZMA and ISO decompression support'
+ 'squashfs-tools: squashfs support'
+ 'tar: TAR archive support'
+ 'bzip2: BZIP2 archive support'
+ 'unrar: RAR decompression support'
+ 'xz: XZ decompression support'
+ 'firmware-mod-kit: cramfs support'
+ 'lhasa: LHA support'
+ 'sleuthkit: forensic analysis support'
+)
+makedepends=('git')
+provides=('bytewalk')
+conflicts=("bytewalk")
+
+build() {
+ cd "${srcdir}/${pkgname}-v${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-v${pkgver}"
+ python setup.py install -O1 --prefix="${pkgdir}/usr"
+ install -Dm 644 *.md -t "${pkgdir}/usr/share/doc/${pkgname}"
+ install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+# vim: ts=2 sw=2 et: