summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDan Ziemba2015-06-27 01:15:28 -0400
committerDan Ziemba2015-06-27 01:15:28 -0400
commit8fbeebe1ad0168d4514ae1f45f627d6ba2dcaa64 (patch)
tree39c5f652b5fda85ffdd72aea06b6145d8f20a3b6 /PKGBUILD
parent697b6295ace4c7e80fd034b112e1896c6652af8b (diff)
downloadaur-8fbeebe1ad0168d4514ae1f45f627d6ba2dcaa64.tar.gz
Improved pkgver function to include all tags
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c5805b428674..678eb237312b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
# Contributor: Christoph Zeiler <archNOSPAM_at_moonblade.dot.org>
pkgname=lbzip2-git
-pkgver=2.2.r92.g9aa5ad4
-pkgrel=3
+pkgver=2.5.r19.gce96731
+pkgrel=1
pkgdesc="A parallel, SMP-based, bzip2-compatible compression utility"
arch=('i686' 'x86_64')
url="http://lbzip2.org/"
@@ -20,7 +20,7 @@ sha256sums=('SKIP')
pkgver() {
cd "$srcdir/$_gitname"
- git describe --long | sed -r 's/([^-]*-g)/r\1/;s/-/./g;s/^v//g'
+ git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g;s/^v//g'
}
build() {