summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJohannes Dewender2015-06-17 16:13:56 +0200
committerJohannes Dewender2015-06-17 16:13:56 +0200
commitc56e2d6ddeb7626ef04d1283d4e58e8052d05423 (patch)
treee6c60859a51d778352f3c85433da8e539c2fab68 /PKGBUILD
downloadaur-c56e2d6ddeb7626ef04d1283d4e58e8052d05423.tar.gz
bzr-stats: import from AUR 3 as 0.1.0+bzr51
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..57c52c5cb938
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Submitter: Carlos Eduardo Moreira dos Santos (cemsbr) <cems at domain cemshost.com.br>
+# Mantainer: iosonofabio Fabio Zanini <fabio.zanini@fastmail.fm>
+
+pkgname=bzr-stats
+pkgver=0.1.0+bzr51
+pkgrel=1
+pkgdesc="Simple statistics plugin for Bazaar."
+arch=('i686' 'x86_64')
+url="http://launchpad.net/bzr-stats"
+license=('GPL')
+depends=('bzr')
+
+source=(https://launchpad.net/debian/wheezy/+source/${pkgname}/${pkgver}-1/+files/${pkgname}_${pkgver}.orig.tar.bz2)
+md5sums=('8a02f3bd22f1c9a37f1ded89151639c9')
+
+iprepare() {
+ cd "${srcdir}/${pkgname}_${pkgver}.orig"
+ # Replace python with python2
+ for file in $(find ./ -name '*.py' -print); do
+ sed -i 's,^#!.*/usr/bin/python,#!/usr/bin/python2,g' $file
+ sed -i 's,^#!.*/usr/bin/env.*python,#!/usr/bin/env python2,g' $file
+ done
+}
+
+build() {
+ cd "${srcdir}/${pkgname}_${pkgver}.orig"
+ python2 ./setup.py install --prefix=/usr --root="${pkgdir}" -O1
+}