summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMartchus2022-08-09 21:31:47 +0200
committerMartchus2022-08-09 21:31:47 +0200
commit5e339c78108590ed729abb8bb91dfe24d77370ac (patch)
tree633ffb8514902552f97e41c516d0767e4f5c64ae /PKGBUILD
parent31f3cd8580dd36eafccd2678a710d0cdfbc3aca9 (diff)
downloadaur-5e339c78108590ed729abb8bb91dfe24d77370ac.tar.gz
Add patch to fix build error with CMake 3.24.0
The build error occurs when building syncthingtray but needs to be fixed here.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 32f2c37ad3c2..46f946d95450 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
_reponame=cpp-utilities
pkgname=c++utilities
pkgver=5.18.0
-pkgrel=1
+pkgrel=2
arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
pkgdesc='Common C++ classes and routines such as argument parser, IO and conversion utilities'
license=('GPL')
@@ -16,11 +16,15 @@ makedepends=('cmake' 'ninja')
checkdepends=('cppunit')
provides=(libc++utilities.so)
url="https://github.com/Martchus/${_reponame}"
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/Martchus/${_reponame}/archive/v${pkgver}.tar.gz")
-sha256sums=('8c194160bf3ff6548741fc8ca4c7378694763a12256eeb59da8e15c01a0681fd')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/Martchus/${_reponame}/archive/v${pkgver}.tar.gz"
+ https://github.com/Martchus/cpp-utilities/commit/aa4be0ef70cf697bafc3c5a1df409067505d91e6.patch)
+sha256sums=('8c194160bf3ff6548741fc8ca4c7378694763a12256eeb59da8e15c01a0681fd'
+ '4f594735749a2bfcd7cc421928bfc7039ed914d985dbdf81b6d8264f8afa6cb1')
prepare() {
cd "$srcdir/${PROJECT_DIR_NAME:-$_reponame-$pkgver}"
+
+ patch -p1 -i "$srcdir"/aa4be0ef70cf697bafc3c5a1df409067505d91e6.patch
}
build() {