summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAmish2018-04-09 22:06:23 +0530
committerAmish2018-04-09 22:06:23 +0530
commit32e06e312bf9c33396ef9398ccfc073a6ded04b5 (patch)
tree5a5095d37ed2dffd1b7c3e68cef0ff7b765d0d21 /PKGBUILD
parent517cc44ee77417fc9fb3a124461d7e53578c1ea5 (diff)
downloadaur-32e06e312bf9c33396ef9398ccfc073a6ded04b5.tar.gz
Update to 0.5.3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 21 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a1457b859058..fe05ce4bec1c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,25 @@
# Maintainer: Amish <contact at via dot aur>
pkgname=c-icap
-pkgver=0.5.2
-pkgrel=3
+pkgver=0.5.3
+pkgrel=1
pkgdesc='Implementation of an ICAP server'
arch=(i686 x86_64)
url='http://c-icap.sourceforge.net/'
license=('GPL' 'LGPL')
source=("http://downloads.sourceforge.net/project/c-icap/c-icap/0.5.x/c_icap-${pkgver}.tar.gz"
- 'c-icap.conf'
'c-icap.service'
'c-icap.tmpfiles'
'c-icap.sysusers'
'c-icap.logrotate')
-sha256sums=('1a9ce61622176eaf068d97d6a00baedbbfca96002c5115c8147b41c95c8164ca'
- '7081377defff06af6dd8cbea9776ad45d45a3eae84a9d109681bb49c9b2f1725'
+sha256sums=('0238508c94a406c7a2c8a0ff9659e7ba631554eda55001b43351bb68f85121d2'
'313ae1b3ff52597158d3a914702d60b16248a8fb8f934e91644f63ad373e6375'
- '485fa1649ad1a63f6f2ec46eb0c8100d8756be0ba99df2cf23aa2fc70f14b27d'
+ 'f13158c82b0ef625d3d142811eaf100de01ab09d8d82b66282f1d80bc78d10dd'
'c903eb86e6968b9d3bd0a9ad3335e8ce76a718b6217251e9dd7e66d5cf1ac94a'
'07d5d98801feb0b20fe3cbbf9f7d00148cbda7b2e9e2bc07d859c1c5aa154926')
backup=('etc/c-icap/c-icap.conf'
+ 'etc/c-icap/c-icap-local.conf'
'etc/c-icap/c-icap.magic'
'etc/logrotate.d/c-icap')
-install=$pkgname.install
build() {
cd "${srcdir}/c_icap-${pkgver}"
@@ -41,17 +39,26 @@ package() {
# fix some bad permissions
find "${pkgdir}"/etc/c-icap/ -type f -print0 | xargs -0 chmod 644
- chmod g-w "${pkgdir}"/var/log
- # remove /var/run directory which should not be packaged
- rmdir "${pkgdir}"/var/run/c-icap/ "${pkgdir}"/var/run/
+ # remove directories which should not be packaged
+ rmdir "${pkgdir}"/var{/{log,run{/c-icap,}},}
- install -Dm644 ../c-icap.conf "${pkgdir}"/etc/c-icap/c-icap.conf
+ # allow more resources and adjust paths
+ sed -i -e 's/^StartServers\s.*/StartServers 10/g' \
+ -e 's/^MaxServers\s.*/MaxServers 50/g' \
+ -e 's/^MaxSpareThreads\s.*/MaxSpareThreads 40/g' \
+ -e 's/^ServerAdmin\s.*/ServerAdmin root@localhost/g' \
+ -e 's/^ServerName\s.*/ServerName localhost/g' \
+ -e 's/^DebugLevel\s.*/DebugLevel 0/g' \
+ -e 's:/usr/local/c-icap/etc:/etc/c-icap:g' \
+ -e 's:/usr/var/log:/var/log/c-icap:g' \
+ -e '$ a\\' \
+ -e '$ a Include c-icap-local.conf' \
+ "${pkgdir}"/etc/c-icap/c-icap.conf{,.default}
+
+ install -Dm644 /dev/null "${pkgdir}"/etc/c-icap/c-icap-local.conf
install -Dm644 ../c-icap.service "${pkgdir}"/usr/lib/systemd/system/c-icap.service
install -Dm644 ../c-icap.tmpfiles "${pkgdir}"/usr/lib/tmpfiles.d/c-icap.conf
install -Dm644 ../c-icap.sysusers "${pkgdir}"/usr/lib/sysusers.d/c-icap.conf
install -Dm644 ../c-icap.logrotate "${pkgdir}"/etc/logrotate.d/c-icap
-
- install -d -m750 "${pkgdir}"/var/log/c-icap
- chown 15:15 "${pkgdir}"/var/log/c-icap
}