summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRicardo Band2016-11-22 15:50:29 +0100
committerRicardo Band2016-11-22 15:50:29 +0100
commita614c73c8b0682be75c1e3525d09b8bac78fd7b2 (patch)
tree10ab1303f8fbefd8c82ef60041ded84660d0570e /PKGBUILD
parente6a79d25c9aa708c7456f7b0cf4459eafe132ffd (diff)
downloadaur-a614c73c8b0682be75c1e3525d09b8bac78fd7b2.tar.gz
now includes submodules and builds properly
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f26552d4925e..d22f6f84ed2f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Ricardo (XenGi) Band <email@ricardo.band>
pkgname=c-lolcat
-pkgver=r27.33ee440
-pkgrel=2
+pkgver=r34.8e95919
+pkgrel=3
pkgdesc="High-performance implementation of lolcat"
arch=('i686' 'x86_64')
url="https://github.com/jaseg/lolcat"
@@ -18,6 +18,11 @@ pkgver() {
printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git describe --always)"
}
+prepare() {
+ cd "$pkgname"
+ git submodule update --init musl
+}
+
build() {
cd "$srcdir/$pkgname"
make