summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorm1ckey2019-12-04 22:46:02 +0100
committerm1ckey2019-12-04 22:46:02 +0100
commit144744f6199adf18b0da8d206d8633a78712b4bc (patch)
tree9c6afb22cacceba9da9c7e77cda7f89f3b4b947f /PKGBUILD
downloadaur-c-macro.tar.gz
init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 18 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cd3bd5616c45
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Michael 'm1ckey' Krickl <ch.michael.krickl@gmail.com>
+
+pkgname=c-macro
+pkgver=1.0.9
+pkgrel=1
+pkgdesc='The C Macro makes your local clipboard easily accessible in your Terminal'
+arch=('any')
+url='https://github.com/rettier/c'
+license=('MIT')
+depends=(bash xclip)
+source=("$pkgname-$pkgver.tar.gz::https://github.com/rettier/c/releases/download/v$pkgver/c_$pkgver.tar.gz")
+sha256sums=('2f7f3dee638fd0047ee6efb59f7002a74f8b29b6adc6e07e02b4962f3465c21a')
+
+package() {
+ cd "$srcdir/c_$pkgver"
+ install -Dm 755 c "$pkgdir/usr/bin/c"
+ ln -s ./c "$pkgdir/usr/bin/cf"
+}