aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRafael Fontenelle2017-07-17 18:41:19 -0300
committerRafael Fontenelle2017-07-17 18:49:34 -0300
commit1f2c190105835447e907889d563c69900335332d (patch)
tree29db0bbc3d43b1f017417e75d5f6fa2b90a916d6 /PKGBUILD
parentda5698b84b2d51dab1ce42863e84a40bf64a769a (diff)
downloadaur-1f2c190105835447e907889d563c69900335332d.tar.gz
Update style and content
Changes in this commit: 1- Update the URL 2- Add quotes to $pkgdir 3- Remove the DER-to-PEM convertion, as it is no longer needed. 4- Another minor changes in style
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 8 insertions, 21 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 28d1fdceccaa..73a9f33e77d1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: Tiago Brait <tiagobrait AT gmail DOT com>
+# Maintainer: Rafael Fontenelle <rafaelff@gnome.org>
+# Contributor: Tiago Brait <tiagobrait AT gmail DOT com>
pkgname=ca-certificates-icp_br
pkgver=20170117
@@ -9,29 +10,15 @@ url="http://www.iti.gov.br/icp-brasil/certificados/188-atualizacao/4530-ac-raiz"
license=('GPL')
depends=('ca-certificates-utils')
makedepends=('unzip' 'openssl')
-source=(
- "icpbr_certs-${pkgver}.zip::http://acraiz.icpbrasil.gov.br/credenciadas/CertificadosAC-ICP-Brasil/ACcompactado.zip"
- )
-
-sha512sums=('6890560f28c547bcfa38134ebcacd52f4256bd64681b01c40642e1cb555b45f6264bc5c4ce32d9986dd256a8a8a497101ce4a82b7fc06e537acce98d6cc49b2d')
+source=("icpbr_certs-${pkgver}.zip::http://acraiz.icpbrasil.gov.br/credenciadas/CertificadosAC-ICP-Brasil/ACcompactado.zip")
+sha512sums=('dead5aa494c12fede80195988c9201082f22b425aaf4937a13d23097aabe6f1ee5facd1f87bf53d8daf99995dd1c96b0f9080a449ee892c079a438b60de02d4c')
package() {
local cert_tag='icp_br'
- cd ${srcdir}
find * -print0 | while read -d $'\0' cert; do
- #some certificates have a .crt extension but come in DER format.
- #convert them
- if [[ "$(file $cert | cut -f2 -d\: | tr -d ' ')" = "data" ]]; then
- msg2 "converting $cert from DER to PEM..."
- cert_der="${cert}.der"
- mv $cert $cert_der
- /usr/bin/openssl x509 -in ${cert_der} -inform der -out $cert
- rm "$cert_der"
- fi
- #some of the cert files have spaces in their names, so just remove the spaces
- #when 'tagging' the certificates
- mv "$cert" "${cert_tag}.${cert//' '/'_'}"
+ # Remove whitespaces from filenames
+ mv "$cert" "$cert_tag.${cert//' '/'_'}"
done
- install -d -m0755 $pkgdir/usr/share/ca-certificates/trust-source/anchors
- install -m0644 *.crt $pkgdir/usr/share/ca-certificates/trust-source/anchors
+ install -d -m0755 "$pkgdir/usr/share/ca-certificates/trust-source/anchors"
+ install -m0644 *.crt "$pkgdir/usr/share/ca-certificates/trust-source/anchors"
}