aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTiago Brait2016-03-30 15:07:28 -0300
committerTiago Brait2016-03-30 15:07:28 -0300
commit3a5ce9aa6c3764cae0f21e1423ec5c1b921eef99 (patch)
treebb6a706ba4c0592dd459311d54e82c9da30c1b1f /PKGBUILD
parent0c93fed23eae7827138ae7ee45f1827385655ac7 (diff)
downloadaur-3a5ce9aa6c3764cae0f21e1423ec5c1b921eef99.tar.gz
bump pkgrel
bumping pkgrel due to change in source filename nice tip from josephgbr
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 15 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a5157c50f7bc..e48b5f19c339 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,8 @@
# Maintainer: Tiago Brait <tiagobrait AT gmail DOT com>
-#2014 tiagobrait
pkgname=ca-certificates-icp_br
pkgver=20160406
-pkgrel=1
+pkgrel=2
pkgdesc="Brazilian government Certification Authorities"
arch=('any')
url="http://www.iti.gov.br/icp-brasil/certificados/188-atualizacao/4530-ac-raiz"
@@ -12,7 +11,7 @@ depends=('ca-certificates-utils')
makedepends=('unzip' 'openssl')
install='ca-certificates-icp_br.install'
source=(
- 'http://acraiz.icpbrasil.gov.br/credenciadas/CertificadosAC-ICP-Brasil/ACcompactado.zip'
+ "icpbr_certs-${pkgver}.zip::http://acraiz.icpbrasil.gov.br/credenciadas/CertificadosAC-ICP-Brasil/ACcompactado.zip"
)
sha512sums=(
@@ -23,18 +22,19 @@ package() {
local cert_tag='icp_br'
cd ${srcdir}
find * -print0 | while read -d $'\0' cert; do
- #some certificates have a .crt extension but come in DER format.
- #convert them
- if [[ "$(file $cert | cut -f2 -d\: | tr -d ' ')" = "data" ]]; then
- msg2 "converting $cert from DER to PEM..."
- cert_der="${cert}.der"
- mv $cert $cert_der
- /usr/bin/openssl x509 -in ${cert_der} -inform der -out $cert
- rm "$cert_der"
- fi
- #some of the cert files have spaces in their names, so just remove the spaces
- #when 'tagging' the certificates
- mv "$cert" "${cert_tag}.${cert//' '/'_'}"; done
+ #some certificates have a .crt extension but come in DER format.
+ #convert them
+ if [[ "$(file $cert | cut -f2 -d\: | tr -d ' ')" = "data" ]]; then
+ msg2 "converting $cert from DER to PEM..."
+ cert_der="${cert}.der"
+ mv $cert $cert_der
+ /usr/bin/openssl x509 -in ${cert_der} -inform der -out $cert
+ rm "$cert_der"
+ fi
+ #some of the cert files have spaces in their names, so just remove the spaces
+ #when 'tagging' the certificates
+ mv "$cert" "${cert_tag}.${cert//' '/'_'}"
+ done
install -d -m0755 $pkgdir/etc/ca-certificates/trust-source/anchors
install -m0644 *.crt $pkgdir/etc/ca-certificates/trust-source/anchors
}