aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRafael Fontenelle2019-10-12 07:53:34 -0300
committerRafael Fontenelle2019-10-12 08:08:46 -0300
commite1cae8989e06f3398871157a6300b2952acb6eda (patch)
treee57e322e08ad33594502af9d319a67d289853800 /PKGBUILD
parentf86d346896f164e5850f2bf5710e22be47a05fd7 (diff)
downloadaur-e1cae8989e06f3398871157a6300b2952acb6eda.tar.gz
Update to 20191010
Previous upstream releases provided a zip file with a directory named "ACcompactado" containing all certificates. This release does not provide such directory, and extracting it would put all certificates to source directory. Added "noextract" option to avoid that behavior.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 8 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6306776ed89e..b19817bdb963 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Tiago Brait <tiagobrait AT gmail DOT com>
pkgname=ca-certificates-icp_br
-pkgver=20190823
+pkgver=20191010
pkgrel=1
pkgdesc="Brazilian government Certification Authorities"
arch=('any')
@@ -11,14 +11,18 @@ license=('unknown')
depends=('ca-certificates-utils')
makedepends=('unzip')
source=("icpbr_certs-${pkgver}-${pkgrel}.zip::http://acraiz.icpbrasil.gov.br/credenciadas/CertificadosAC-ICP-Brasil/ACcompactado.zip")
-sha512sums=('540a9b6d77def3c04d00eeff44007df63abc20fc62cfb0c542adc0ce28ebdc2de4eb16a99f82c7b1404406a738044f987b80c4d4faab68bcad17a59f823af5d4')
+sha512sums=('a48401fefc961218f3a16b803cfc2ea97df50d39358dcd06e7b94c31a08248a25ced82421604e3e5fe9d683b7db4c975199d4f0fd061b0f924eb62f7a1081983')
+noextract=("icpbr_certs-${pkgver}-${pkgrel}.zip")
+
+_source="icpbr_certs-${pkgver}-${pkgrel}"
prepare() {
- mv ACcompactado icpbr_certs-${pkgver}-${pkgrel}
+ rm -rf "$_source" && mkdir "$_source"
+ unzip -q "$_source.zip" -d "$_source"
}
package() {
- cd icpbr_certs-${pkgver}-${pkgrel}
+ cd "$_source"
find * -print0 | while read -d $'\0' cert; do
# Edit filenames removing whitespaces and prepending 'icp_br'