aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRafael Fontenelle2019-08-23 15:25:52 -0300
committerRafael Fontenelle2019-08-23 15:25:55 -0300
commitf86d346896f164e5850f2bf5710e22be47a05fd7 (patch)
tree31ce9adfcc2c3af4a32081381ff165572a0b1ced /PKGBUILD
parent18aae730d8dacfb35ff7d66d9a658b992e0cbd68 (diff)
downloadaur-f86d346896f164e5850f2bf5710e22be47a05fd7.tar.gz
Update to 20190823
This version of source zip file inovated in having all certificates inside a "ACcompactado.zip" directory, so PKGBUILD adjusted to fit this change. Before it didn't have a directory, so everything was extracted to $srcdir.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2ce9758c39be..6306776ed89e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Tiago Brait <tiagobrait AT gmail DOT com>
pkgname=ca-certificates-icp_br
-pkgver=20190722
+pkgver=20190823
pkgrel=1
pkgdesc="Brazilian government Certification Authorities"
arch=('any')
@@ -11,9 +11,15 @@ license=('unknown')
depends=('ca-certificates-utils')
makedepends=('unzip')
source=("icpbr_certs-${pkgver}-${pkgrel}.zip::http://acraiz.icpbrasil.gov.br/credenciadas/CertificadosAC-ICP-Brasil/ACcompactado.zip")
-sha512sums=('d7e7f95347edca23f0d8712227bfc3d625548114db709e7ad0760302c40d6cd60ae2fcf17cc6d3017cb4aa39e36f23afeb3000fea2eea3f78b21dfb5b09fa8cd')
+sha512sums=('540a9b6d77def3c04d00eeff44007df63abc20fc62cfb0c542adc0ce28ebdc2de4eb16a99f82c7b1404406a738044f987b80c4d4faab68bcad17a59f823af5d4')
+
+prepare() {
+ mv ACcompactado icpbr_certs-${pkgver}-${pkgrel}
+}
package() {
+ cd icpbr_certs-${pkgver}-${pkgrel}
+
find * -print0 | while read -d $'\0' cert; do
# Edit filenames removing whitespaces and prepending 'icp_br'
mv "$cert" "icp_br.${cert//' '/'_'}"