summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMantas Mikulėnas2015-08-08 18:25:17 +0300
committerMantas Mikulėnas2015-08-08 18:25:34 +0300
commite2ce7e8f1ec4a6f54e3cd984079995459a5664ce (patch)
tree7cfc28689e090218aa0f101827a7732f700fc754 /PKGBUILD
downloadaur-e2ce7e8f1ec4a6f54e3cd984079995459a5664ce.tar.gz
initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d51a094a5bf1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Rémy Oudompheng <remy@archlinux.org>
+
+pkgname=cachefilesd
+pkgver=0.10.5
+pkgrel=1
+pkgdesc="Userspace daemon acting as a backend for FS-Cache"
+arch=('i686' 'x86_64')
+url="http://people.redhat.com/~dhowells/fscache/"
+license=('GPL')
+depends=('glibc')
+source=(http://people.redhat.com/~dhowells/fscache/${pkgname}-${pkgver}.tar.bz2
+ cachefilesd)
+backup=(etc/cachefilesd.conf)
+md5sums=('9e85dd0ace346ff47e188ded8c05ab3b'
+ 'a4f0c47a945f296f120e29f156aea9ba')
+
+build() {
+ cd "$pkgname-$pkgver"
+ make CFLAGS="$CFLAGS"
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+ install -D -m 755 "${srcdir}/cachefilesd" "${pkgdir}/etc/rc.d/cachefilesd"
+}