summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTarn Burton2017-01-04 16:01:53 -0500
committerTarn Burton2017-01-04 16:01:53 -0500
commit6693c3848c39be544ee8de6cb3b86e1af3f5fed0 (patch)
tree1adf2176842622df5802c0adf745e2c8982f41bb /PKGBUILD
downloadaur-6693c3848c39be544ee8de6cb3b86e1af3f5fed0.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6c2d7a2ab9ff
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Tarn Burton <twburton at gmail dot com>
+pkgname='cadabra2'
+pkgver=2.1.2
+pkgrel=1
+pkgdesc="A computer algebra system designed specifically for the solution of problems encountered in field theory."
+arch=('i686' 'x86_64')
+url="http://cadabra.science/"
+license=('GPL')
+provides=('cadabra2')
+conflicts=('cadabra2')
+depends=('python-matplotlib' 'gtkmm3' 'jsoncpp' 'mathjax' 'boost-libs' 'python-sympy' 'texlive-core')
+makedepends=('cmake' 'boost')
+source=("$pkgname::git+https://github.com/kpeeters/cadabra2#tag=$pkgver" "package.patch")
+md5sums=('SKIP'
+ 'b04444f9ba31aa482dd88473dd90d59b')
+install=package.install
+
+prepare() {
+ cd "${srcdir}/${pkgname}"
+ patch -Np1 -i ../package.patch
+}
+
+build() {
+ cd $pkgname
+ mkdir -p build
+ cd build
+ cmake -DCMAKE_SKIP_RPATH=true -DCMAKE_INSTALL_PREFIX=/usr ..
+ make
+}
+
+package() {
+ cd "${pkgname}/build"
+ make DESTDIR="${pkgdir}" install
+}