summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTarn Burton2016-05-22 13:17:45 -0400
committerTarn Burton2016-05-22 13:17:45 -0400
commit11e55c2fe2703332c511d927500d8d04db0623b6 (patch)
tree6c72c9dff4d8d89043c8344de574cb36a77a6ed3 /PKGBUILD
parent2f77e51ca67a5aec1a6d0aaf167ed5897415b9dd (diff)
downloadaur-11e55c2fe2703332c511d927500d8d04db0623b6.tar.gz
Update for python3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 5 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a52b8a0ce2ed..28c47f9a7dd2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Tarn Burton <twburton at gmail dot com>
pkgname='cadabra2-git'
-pkgver=r716.6c7ef1c
+pkgver=r721.b39670b
pkgrel=1
pkgdesc="A computer algebra system (pre-release version) designed specifically for the solution of problems encountered in field theory."
arch=('i686' 'x86_64')
@@ -8,11 +8,10 @@ url="http://cadabra.phi-sci.com/"
license=('GPL')
provides=('cadabra2')
conflicts=('cadabra2')
-depends=('python2-matplotlib' 'gtkmm3' 'jsoncpp' 'mathjax' 'boost-libs' 'python2-sympy')
-makedepends=('cmake')
-source=("$pkgname::git+https://github.com/kpeeters/cadabra2" "package.patch")
-md5sums=('SKIP'
- '0b5e5e066145f974b8be4f92af0055f0')
+depends=('python-matplotlib' 'gtkmm3' 'jsoncpp' 'mathjax' 'boost-libs' 'python-sympy')
+makedepends=('cmake' 'boost')
+source=("$pkgname::git+https://github.com/kpeeters/cadabra2")
+md5sums=('SKIP')
install=package.install
@@ -21,11 +20,6 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-prepare() {
- cd "${srcdir}/${pkgname}"
- patch -Np1 -i ../package.patch
-}
-
build() {
cd $pkgname
mkdir -p build