summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2017-03-27 14:57:36 -0300
committerDaniel Bermond2017-03-27 14:57:36 -0300
commit7ebdec03a2f785269a21f9b7042f86b4eeb393fc (patch)
tree5e0936ea92baaf0180a90deae203c49b16070fc2 /PKGBUILD
parent177018e7a8308bbaba3029800a15e57acca66298 (diff)
downloadaur-7ebdec03a2f785269a21f9b7042f86b4eeb393fc.tar.gz
build(): reorganized the python2 block
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4da5248aa10d..57815f2c436e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=caffe-git
pkgver=rc5.r5.g317d162ac
-pkgrel=3
+pkgrel=4
pkgdesc="A deep learning framework made with expression, speed, and modularity in mind (git version, gpu enabled)"
arch=('x86_64')
url="http://caffe.berkeleyvision.org/"
@@ -69,13 +69,13 @@ prepare() {
# use python layers
sed -i '/WITH_PYTHON_LAYER/s/^#[[:space:]]//g' Makefile.config
+ # if you want to use python2 _instead_ of python3:
+ # - uncomment this block
+ # - comment the python3 block
+ # - change python3 dependencies to python2
+ # - NOTE: do not enable both python2 and python3 blocks. choose only one.
+ # - NOTE: python2 is the Caffe default but this package uses python3 by default
# python2 settings
- # if you want to use python2 _instead_ of python3:
- # - uncomment this block
- # - comment the python3 block
- # - change python3 depends and optdepends to python2
- # - NOTE: do not enable both python2 and python3 blocks. choose only one.
- # - NOTE: python2 is the Caffe default but this package uses python3 by default
#_py2inc_line="$(sed -n '/PYTHON_INCLUDE[[:space:]]\:=[[:space:]]\/usr\/include\/python2\.7/=' Makefile.config)"
#sed -i "$((_py2inc_line+1))s/dist/site/" Makefile.config
}