summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2017-03-27 14:59:08 -0300
committerDaniel Bermond2017-03-27 14:59:08 -0300
commit842726d5cf455fb7bc383ffaa693769eac45ca99 (patch)
tree235c902cd5a90816c9b6457431611fd531993464 /PKGBUILD
parent7ebdec03a2f785269a21f9b7042f86b4eeb393fc (diff)
downloadaur-842726d5cf455fb7bc383ffaa693769eac45ca99.tar.gz
Added check() as a comment block
It takes really a lot of time to run the tests (it likely triples the building time in a i7 4.0GHz + GTX 750 machine) and it will prevent the package to be built in case of error. So it is not enabled by default and is added as a comment block. Users that need to make the tests should manually enable it. At the time of this writing I'm getting a 100% success tests. You can say that there is makepkg '--nocheck' option but the intention here is to not enable tests by default. Still, many people can forget about the makepkg '--nocheck' option in case of failure.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 12 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 57815f2c436e..d9cb526022c3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
# Contributor: Jonathan Yantis
pkgname=caffe-git
-pkgver=rc5.r5.g317d162ac
-pkgrel=4
+pkgver=rc5.r9.g793bd9635
+pkgrel=1
pkgdesc="A deep learning framework made with expression, speed, and modularity in mind (git version, gpu enabled)"
arch=('x86_64')
url="http://caffe.berkeleyvision.org/"
@@ -100,6 +100,16 @@ build() {
make distribute
}
+# uncomment this block if you want to run the checks/tests
+# (usually takes a lot of time; it will prevent package to be built in case of error)
+#check() {
+# cd "$pkgname"
+# msg2 "Building target 'test'..."
+# make test
+# msg2 "Making target 'runtest'..."
+# make runtest
+#}
+
package() {
# directories creation
mkdir -p "${pkgdir}/usr/bin"