summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2017-05-01 16:25:47 -0300
committerDaniel Bermond2017-05-01 16:25:47 -0300
commit0e59b4945723b2a79d1a80473d2f1d273f01ae45 (patch)
tree574936db2d8445ff0d03ed2a0d59e3a72d448dbb /PKGBUILD
parentad4b987ae5bdb672123d724ce9423b73e6cc901e (diff)
downloadaur-0e59b4945723b2a79d1a80473d2f1d273f01ae45.tar.gz
Strictly added gcc5 to makedepends and cuda to depends
cudnn already pulls cuda. The current version of cuda (8.0) already pulls gcc5. But strictly adding them the dependencies can avoid some problems in the future.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3b8b003d9ac0..98ffe7188068 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,7 +14,7 @@ _gitwebver=master
pkgname=caffe2
pkgver=0.7.0
-pkgrel=2
+pkgrel=3
pkgdesc="A new lightweight, modular, and scalable deep learning framework (gpu enabled)"
arch=('x86_64')
url="http://caffe2.ai/"
@@ -22,7 +22,7 @@ license=('BSD')
depends=(
# binary repositories:
# required:
- 'google-glog' 'protobuf' 'python2' 'python2-numpy' 'python2-protobuf'
+ 'google-glog' 'protobuf' 'python2' 'python2-numpy' 'python2-protobuf' 'cuda'
# not required but enabled in build:
'gflags' 'gtest' 'openmp' 'leveldb' 'lmdb' 'opencv' 'openmpi' 'snappy'
'zeromq' 'hiredis'
@@ -41,7 +41,7 @@ depends=(
# missing:
# 'python2-nvd3'
)
-makedepends=('cmake')
+makedepends=('cmake' 'gcc5')
conflicts=('caffe' 'caffe-cpu' 'caffe-git' 'caffe-cpu-git'
'caffe2-git' 'caffe2-cpu' 'caffe2-cpu-git')
options=('!emptydirs')