summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2017-08-23 16:05:56 -0300
committerDaniel Bermond2017-08-23 16:05:56 -0300
commit312209cc7cdcc6ad4e8f0f68a72bedc3011c7284 (patch)
tree9314cd99f5b68b20427fd18a3405070a477ad61d /PKGBUILD
parent71486849705b418be03ed2e5f38a698f74822576 (diff)
downloadaur-312209cc7cdcc6ad4e8f0f68a72bedc3011c7284.tar.gz
Added missing python dependencies (six, future and nvd3)
Adding python-future fixes an error when importing the caffe2 python modules. Thanks to AUR user wangqr for pointing this.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 7 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6583f263d8ae..03c8afed2a09 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -23,7 +23,7 @@ _protobuf_version='3.1.0' # commit 'a428e42072765993ff674fda72863c9f1aa2d268' is
pkgname=caffe2
pkgver=0.8.1
-pkgrel=1
+pkgrel=2
pkgdesc='A new lightweight, modular, and scalable deep learning framework (gpu enabled)'
arch=('x86_64')
url='http://caffe2.ai/'
@@ -37,17 +37,16 @@ depends=(
'gflags' 'gtest' 'openmp' 'leveldb' 'lmdb' 'openmpi' 'snappy' 'zeromq'
'hiredis'
# python2:
- 'python2-pydot' 'python2-flask' 'graphviz' 'python2-hypothesis'
- 'python2-jupyter_core' 'python2-matplotlib' 'python2-yaml' 'python2-requests'
- 'python2-scipy' 'python2-setuptools' 'python2-tornado' 'python2-pyzmq'
- 'python2-gflags'
+ 'python2-flask' 'python2-future' 'graphviz' 'python2-hypothesis'
+ 'python2-jupyter_core' 'python2-matplotlib' 'python2-pydot' 'python2-yaml'
+ 'python2-requests' 'python2-scipy' 'python2-setuptools' 'python2-six'
+ 'python2-tornado' 'python2-gflags' 'python2-pyzmq'
# AUR:
# not required but enabled in build:
'nccl'
# python2:
- 'python2-scikit-image' 'python2-leveldb' 'python2-lmdb' 'python2-glog'
- # missing:
- # 'python2-nvd3'
+ 'python2-nvd3' 'python2-scikit-image' 'python2-glog' 'python2-leveldb'
+ 'python2-lmdb'
)
makedepends=(
# official repositories: