summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2017-08-09 14:14:49 -0300
committerDaniel Bermond2017-08-09 14:14:49 -0300
commit71486849705b418be03ed2e5f38a698f74822576 (patch)
tree014d302fd27e5f0618b2edb34eac4fe3de8a6515 /PKGBUILD
parent894fb0890375500b0629e13ff2ad457244eaf68f (diff)
downloadaur-71486849705b418be03ed2e5f38a698f74822576.tar.gz
Updated to version 0.8.1
This version adds support for the newly released cudnn 7.0.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 7 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8a3cd190736c..6583f263d8ae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
_android_cmake_commit='556cc14296c226f753a3778d99d8b60778b7df4f'
_benchmark_commit='4bf28e611b55de8a2d4eece3c335e014f8b0f630'
_cnmem_commit='28a182d49529da49f4ac4e3941cec3edf16b3540'
-_cub_commit='89de7ab20167909bc2c4f8acd397671c47cf3c0d'
-_gloo_commit='21a5c8ea5e02edca03068790df3d7f7ba4e2d75b'
+_cub_commit='b1370adb972a8345de92e2d69e61daf7f9bce43e'
+_gloo_commit='530878247b04c423fd35477208f68e70b8126e2d'
_googletest_commit='5e7fd50e17b6edf1cadff973d0ec68966cf3265e'
_ios_cmake_commit='e24081928d9ceec4f4adfcf12293f1e2a20eaedc'
_nccl_commit='2a974f5ca2aa12b178046b2206b43f1fd69d9fae'
@@ -21,14 +21,8 @@ _nnpackdeps_pthreadpool_commit='9e17903a3fc963fe86b151aaddae7cf1b1d34815'
_eigen_version='3.3.2' # commit 'ae9889a130bd0a9d3007f41d015563c2e8ac605f' is version '3.3.2'
_protobuf_version='3.1.0' # commit 'a428e42072765993ff674fda72863c9f1aa2d268' is version '3.1.0'
-# note about modified gloo commit:
-# the gloo target commit is 7ea9d9af4e82d20c7c6cee5edd3c52f9bcb42821, but
-# it's necessary to use a newer commit to avoid compile errors if using
-# '-march=native' in a cpu with AVX2:
-# https://github.com/facebookincubator/gloo/issues/43
-
pkgname=caffe2
-pkgver=0.8.0
+pkgver=0.8.1
pkgrel=1
pkgdesc='A new lightweight, modular, and scalable deep learning framework (gpu enabled)'
arch=('x86_64')
@@ -38,7 +32,7 @@ depends=(
# official repositories:
# required:
'google-glog' 'protobuf' 'python2' 'python2-numpy' 'python2-protobuf' 'cuda'
- 'cudnn>=5.1' 'cudnn<7.0'
+ 'cudnn'
# not required but enabled in build:
'gflags' 'gtest' 'openmp' 'leveldb' 'lmdb' 'openmpi' 'snappy' 'zeromq'
'hiredis'
@@ -67,7 +61,6 @@ options=('!emptydirs')
source=(
# main source:
"${pkgname}-${pkgver}.tar.gz"::"https://github.com/${pkgname}/${pkgname}/archive/v${pkgver}.tar.gz"
- 'external-nnpack-fix.patch'
# third party:
'thirdparty-android-cmake-git'::"git+https://github.com/taka-no-me/android-cmake.git#commit=${_android_cmake_commit}"
'thirdparty-benchmark-git'::"git+https://github.com/google/benchmark.git#commit=${_benchmark_commit}"
@@ -89,8 +82,7 @@ source=(
)
noextract=("thirdparty-eigen-${_eigen_version}.tar.gz"
"thirdparty-protobuf-${_protobuf_version}.tar.gz")
-sha256sums=('3c46d2324046774e96601bad737cdce05084cab80b9109c48a09f332438b921c'
- '1c94a1ecc0fe2a52c50c9d1a7bfca655d60c08d48995b27c73aa22b6c375da54'
+sha256sums=('2b7938514caf626da3fdde51e88771adc863cbe496d0fc4ae1122603a945e9a8'
'SKIP'
'SKIP'
'SKIP'
@@ -107,8 +99,7 @@ sha256sums=('3c46d2324046774e96601bad737cdce05084cab80b9109c48a09f332438b921c'
'SKIP'
'SKIP'
'SKIP'
- 'SKIP'
-)
+ 'SKIP')
prepare() {
cd "${pkgname}-${pkgver}/third_party"
@@ -139,11 +130,6 @@ prepare() {
done
unset _component
-
- # avoid compile errors with nnpack if system library is found
- # https://github.com/caffe2/caffe2/commit/f070eb99a4a36f12abbdb9af98bb68ff485c840b
- cd "${srcdir}/${pkgname}-${pkgver}"
- patch -Np1 -i "${srcdir}/external-nnpack-fix.patch"
}
build() {
@@ -214,6 +200,7 @@ build() {
-DUSE_NERVANA_GPU:BOOL='ON' \
-DUSE_NNPACK:BOOL='ON' \
-DUSE_OPENCV:BOOL='OFF' \
+ -DUSE_FFMPEG:BOOL='OFF' \
-DUSE_OPENMP:BOOL='ON' \
-DUSE_REDIS:BOOL='ON' \
-DUSE_ROCKSDB:BOOL='OFF' \