summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2017-06-15 20:40:58 -0300
committerDaniel Bermond2017-06-15 20:40:58 -0300
commit7763c6338fffb7b14d658807338904a7b59e0992 (patch)
treec195772b472c502c026bed21808a3b87ccfe238c /PKGBUILD
parentec8b04ae392bbb0f19404ef514aefcbcc1913534 (diff)
downloadaur-7763c6338fffb7b14d658807338904a7b59e0992.tar.gz
Added nnpack support
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 15 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 35d2021c95b5..46fb2aea0cdc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -23,7 +23,7 @@ _protobuf_version='3.1.0' # commit 'a428e42072765993ff674fda72863c9f1aa2d268' is
pkgname=caffe2
pkgver=0.7.0
-pkgrel=9
+pkgrel=10
pkgdesc='A new lightweight, modular, and scalable deep learning framework (gpu enabled)'
arch=('x86_64')
url='http://caffe2.ai/'
@@ -49,13 +49,19 @@ depends=(
# missing:
# 'python2-nvd3'
)
-makedepends=('cmake' 'gcc5')
+makedepends=(
+ # official repositories:
+ 'git' 'cmake' 'gcc5' 'ninja'
+ # AUR:
+ 'confu-git' 'python-peachpy-git'
+)
conflicts=('caffe' 'caffe-cpu' 'caffe-git' 'caffe-cpu-git'
'caffe2-git' 'caffe2-cpu' 'caffe2-cpu-git')
options=('!emptydirs')
source=(
# main source:
"${pkgname}-${pkgver}.tar.gz"::"https://github.com/${pkgname}/${pkgname}/archive/v${pkgver}.tar.gz"
+ 'external-nnpack-fix.patch'
# third party:
'thirdparty-android-cmake-git'::"git+https://github.com/taka-no-me/android-cmake.git#commit=${_android_cmake_commit}"
'thirdparty-benchmark-git'::"git+https://github.com/google/benchmark.git#commit=${_benchmark_commit}"
@@ -78,6 +84,7 @@ source=(
noextract=("thirdparty-eigen-${_eigen_version}.tar.gz"
"thirdparty-protobuf-${_protobuf_version}.tar.gz")
sha256sums=('b8f266ed283efc172fa96c06c878ed7f125755f89cde480580b754c1f03c0bab'
+ '1c94a1ecc0fe2a52c50c9d1a7bfca655d60c08d48995b27c73aa22b6c375da54'
'SKIP'
'SKIP'
'SKIP'
@@ -126,6 +133,11 @@ prepare() {
done
unset _component
+
+ # avoid compile errors with nnpack if system library is found
+ # https://github.com/caffe2/caffe2/pull/808
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ patch -Np1 -i "${srcdir}/external-nnpack-fix.patch"
}
build() {
@@ -193,7 +205,7 @@ build() {
-DUSE_MPI:BOOL=ON \
-DUSE_NCCL:BOOL=ON \
-DUSE_NERVANA_GPU:BOOL=ON \
- -DUSE_NNPACK:BOOL=OFF \
+ -DUSE_NNPACK:BOOL=ON \
-DUSE_OPENCV:BOOL=OFF \
-DUSE_OPENMP:BOOL=ON \
-DUSE_REDIS:BOOL=ON \