summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2017-09-03 13:45:41 -0300
committerDaniel Bermond2017-09-03 13:45:41 -0300
commitb40c59c50be3e8c5f1e0fe3b06dac1416a495d46 (patch)
treef5e394f8ac5a161ab63a0cf85797add69dd93a87 /PKGBUILD
parent50c5c4a68c387a4fb85cf799d14f550b1b798d9c (diff)
downloadaur-b40c59c50be3e8c5f1e0fe3b06dac1416a495d46.tar.gz
Removed NCCL support
The newly released NCCL version 2 requires registration at the NVIDIA developer webiste and a manual download. As this breaks automated builds by AUR helpers, NCCL was disabled by default in this package.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a83eb5746052..d36d159eb354 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -23,7 +23,7 @@ _protobuf_version='3.1.0' # commit 'a428e42072765993ff674fda72863c9f1aa2d268' is
pkgname=caffe2
pkgver=0.8.1
-pkgrel=3
+pkgrel=4
pkgdesc='A new lightweight, modular, and scalable deep learning framework (gpu enabled)'
arch=('x86_64')
url='http://caffe2.ai/'
@@ -42,8 +42,8 @@ depends=(
'python2-requests' 'python2-scipy' 'python2-setuptools' 'python2-six'
'python2-tornado' 'python2-gflags' 'python2-pyzmq'
# AUR:
- # not required but enabled in build:
- 'nccl'
+ # not required:
+ # 'nccl'
# python2:
'python2-nvd3' 'python2-scikit-image' 'python2-glog' 'python2-leveldb'
'python2-lmdb'
@@ -195,7 +195,7 @@ build() {
-DUSE_LITE_PROTO:BOOL='OFF' \
-DUSE_LMDB:BOOL='ON' \
-DUSE_MPI:BOOL='ON' \
- -DUSE_NCCL:BOOL='ON' \
+ -DUSE_NCCL:BOOL='OFF' \
-DUSE_NERVANA_GPU:BOOL='ON' \
-DUSE_NNPACK:BOOL='ON' \
-DUSE_OBSERVERS:BOOL='ON' \