summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2017-06-15 19:20:37 -0300
committerDaniel Bermond2017-06-15 19:20:37 -0300
commitf28dd4f18a4e29c0ab14affeed69684f4efcda3d (patch)
tree1278f146f44883a15bf604d9bd97bbdb9bd12862 /PKGBUILD
parentf578f8bb31abbfe8e3d49759949451adb13e70fb (diff)
downloadaur-f28dd4f18a4e29c0ab14affeed69684f4efcda3d.tar.gz
Removed opencv from build
Compiling with opencv currently is giving linking errors with libtbb.so (intel-tbb, enabled in opencv). Temporarily disabled opencv until it can be fixed.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b9b98dbd0320..bec493c6a6df 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,7 @@ _gitwebver=master
pkgname=caffe2
pkgver=0.7.0
-pkgrel=6
+pkgrel=7
pkgdesc="A new lightweight, modular, and scalable deep learning framework (gpu enabled)"
arch=('x86_64')
url="http://caffe2.ai/"
@@ -24,8 +24,8 @@ depends=(
'google-glog' 'protobuf' 'python2' 'python2-numpy' 'python2-protobuf' 'cuda'
'cudnn'
# not required but enabled in build:
- 'gflags' 'gtest' 'openmp' 'leveldb' 'lmdb' 'opencv' 'openmpi' 'snappy'
- 'zeromq' 'hiredis'
+ 'gflags' 'gtest' 'openmp' 'leveldb' 'lmdb' 'openmpi' 'snappy' 'zeromq'
+ 'hiredis'
# python2:
'python2-pydot' 'python2-flask' 'graphviz' 'python2-hypothesis'
'python2-jupyter_core' 'python2-matplotlib' 'python2-yaml' 'python2-requests'
@@ -192,7 +192,7 @@ build() {
-DUSE_NCCL:BOOL=ON \
-DUSE_NERVANA_GPU:BOOL=ON \
-DUSE_NNPACK:BOOL=OFF \
- -DUSE_OPENCV:BOOL=ON \
+ -DUSE_OPENCV:BOOL=OFF \
-DUSE_OPENMP:BOOL=ON \
-DUSE_REDIS:BOOL=ON \
-DUSE_ROCKSDB:BOOL=OFF \