summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2017-06-14 22:11:58 -0300
committerDaniel Bermond2017-06-14 22:11:58 -0300
commit669d772102dc688e96773a08ce37be9fc5e241e7 (patch)
tree2f4d18a33fb391f695801d6cb712dbdc74efc1d6 /PKGBUILD
parent4959786d4b36948fadff75c18e30d389895b326b (diff)
downloadaur-669d772102dc688e96773a08ce37be9fc5e241e7.tar.gz
Fix compile error with gloo
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 51949f73d0cb..39a3f2db403f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=caffe2-git
pkgver=0.7.0.r252.ge6c6b859
-pkgrel=1
+pkgrel=2
pkgdesc="A new lightweight, modular, and scalable deep learning framework (git version, gpu enabled)"
arch=('x86_64')
url="http://caffe2.ai/"
@@ -87,6 +87,11 @@ prepare() {
git config "submodule.third_party/${_submodule}.url" "${srcdir}/${_submodule_dir}"
done
git submodule update
+
+ # avoid errors with gloo if using '-march=native' in a cpu with AVX2
+ # https://github.com/facebookincubator/gloo/issues/43
+ cd third_party/gloo
+ git checkout 21a5c8ea5e02edca03068790df3d7f7ba4e2d75b
}
pkgver() {
@@ -190,7 +195,6 @@ package() {
mkdir -p "${pkgdir}/usr/share/licenses/${pkgname}"
# move/rename folders to the right location
- mv -f "${pkgdir}/usr/binaries" "${pkgdir}/usr/bin"
mv -f "${pkgdir}/usr/caffe" "${pkgdir}/usr/lib/python2.7/site-packages"
mv -f "${pkgdir}/usr/caffe2" "${pkgdir}/usr/lib/python2.7/site-packages"