summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2017-08-23 15:59:09 -0300
committerDaniel Bermond2017-08-23 15:59:09 -0300
commitca34ef263cb4a3dd1976c5d942df797be0cc8a0e (patch)
treee0c8aab53ce79bb02092e0ae224890568685a172 /PKGBUILD
parentfa6cf7cca8aa3d2eeb34634778347e349296d56b (diff)
downloadaur-ca34ef263cb4a3dd1976c5d942df797be0cc8a0e.tar.gz
Added missing python dependencies (six, future and nvd3)
Adding python-future fixes an error when importing the caffe2 python modules. Thanks to AUR user wangqr for pointing this.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 7 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f3191ce087f3..b2b56bc2131a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=caffe2-git
pkgver=0.8.1.r19.gf0ea8046
-pkgrel=1
+pkgrel=2
pkgdesc='A new lightweight, modular, and scalable deep learning framework (git version, gpu enabled)'
arch=('x86_64')
url='http://caffe2.ai/'
@@ -16,17 +16,16 @@ depends=(
'gflags' 'gtest' 'openmp' 'leveldb' 'lmdb' 'openmpi' 'snappy' 'zeromq'
'hiredis'
# python2:
- 'python2-pydot' 'python2-flask' 'graphviz' 'python2-hypothesis'
- 'python2-jupyter_core' 'python2-matplotlib' 'python2-yaml' 'python2-requests'
- 'python2-scipy' 'python2-setuptools' 'python2-tornado' 'python2-pyzmq'
- 'python2-gflags'
+ 'python2-flask' 'python2-future' 'graphviz' 'python2-hypothesis'
+ 'python2-jupyter_core' 'python2-matplotlib' 'python2-pydot' 'python2-yaml'
+ 'python2-requests' 'python2-scipy' 'python2-setuptools' 'python2-six'
+ 'python2-tornado' 'python2-gflags' 'python2-pyzmq'
# AUR:
# not required but enabled in build:
'nccl'
# python2:
- 'python2-scikit-image' 'python2-leveldb' 'python2-lmdb' 'python2-glog'
- # missing:
- # 'python2-nvd3'
+ 'python2-nvd3' 'python2-scikit-image' 'python2-glog' 'python2-leveldb'
+ 'python2-lmdb'
)
makedepends=(
# official repositories: