summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2017-10-19 15:26:26 -0200
committerDaniel Bermond2017-10-19 15:26:26 -0200
commitf39bc06c770fd1dddc3362cadc9427e7f2186f11 (patch)
tree7d4fa2a9cf98b47295f227cc28ff0ab6b6ea9e45 /PKGBUILD
parentc2345c3d4e3f7692ba33de3b20ee2b84d3c5f971 (diff)
downloadaur-f39bc06c770fd1dddc3362cadc9427e7f2186f11.tar.gz
New upstream git submodule: aten
References ---------- https://github.com/caffe2/caffe2/commit/acd1aef483c168e929ca56b2a6fe958ecb40e46b
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d5b06a0c387e..bcc10046f2d6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,8 +10,8 @@
# -DNCCL_ROOT_DIR:PATH='/opt/cuda'
pkgname=caffe2-git
-pkgver=0.8.1.r509.g27747b79
-pkgrel=2
+pkgver=0.8.1.r525.g20edf4eb
+pkgrel=1
pkgdesc='A new lightweight, modular, and scalable deep learning framework (git version, gpu enabled)'
arch=('x86_64')
url='http://caffe2.ai/'
@@ -66,6 +66,7 @@ source=(
'submodule-NNPACK_deps-FXdiv'::'git+https://github.com/Maratyszcza/FXdiv.git'
'submodule-NNPACK_deps-FP16'::'git+https://github.com/Maratyszcza/FP16.git'
'submodule-NNPACK_deps-psimd'::'git+https://github.com/Maratyszcza/psimd.git'
+ 'submodule-aten'::'git+https://github.com/zdevito/ATen.git'
)
sha256sums=('SKIP'
'SKIP'
@@ -83,6 +84,7 @@ sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
'SKIP')
prepare() {
@@ -90,11 +92,11 @@ prepare() {
local _submodule_list="pybind11 nccl cub eigen googletest nervanagpu benchmark \
protobuf android-cmake ios-cmake NNPACK gloo \
NNPACK_deps/pthreadpool NNPACK_deps/FXdiv NNPACK_deps/FP16 \
- NNPACK_deps/psimd"
+ NNPACK_deps/psimd aten"
git submodule init
for _submodule in $_submodule_list
do
- local _submodule_dir="submodule-$(printf "%s" "${_submodule}" | tr '/' '-')"
+ local _submodule_dir="submodule-$(printf '%s' "${_submodule}" | tr '/' '-')"
git config --local "submodule.third_party/${_submodule}.url" "${srcdir}/${_submodule_dir}"
done
unset _submodule