summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2017-08-09 22:28:49 -0300
committerDaniel Bermond2017-08-09 22:28:49 -0300
commitfa6cf7cca8aa3d2eeb34634778347e349296d56b (patch)
tree8bf377c4acf9b86a28bd3a64955f7d02521bd735 /PKGBUILD
parent3efee676b70c4a9bebff394bf64f69d0747bd51f (diff)
downloadaur-fa6cf7cca8aa3d2eeb34634778347e349296d56b.tar.gz
Sync with upstream changes: android-cmake, cudnn and gloo
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 3 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 05e03e576bc3..f3191ce087f3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer : Daniel Bermond < yahoo-com: danielbermond >
pkgname=caffe2-git
-pkgver=0.8.0.r126.g21d0d767
+pkgver=0.8.1.r19.gf0ea8046
pkgrel=1
pkgdesc='A new lightweight, modular, and scalable deep learning framework (git version, gpu enabled)'
arch=('x86_64')
@@ -11,7 +11,7 @@ depends=(
# official repositories:
# required:
'google-glog' 'protobuf' 'python2' 'python2-numpy' 'python2-protobuf' 'cuda'
- 'cudnn>=5.1' 'cudnn<7.0'
+ 'cudnn'
# not required but enabled in build:
'gflags' 'gtest' 'openmp' 'leveldb' 'lmdb' 'openmpi' 'snappy' 'zeromq'
'hiredis'
@@ -51,7 +51,7 @@ source=(
'submodule-nervanagpu'::'git+https://github.com/NervanaSystems/nervanagpu.git'
'submodule-benchmark'::'git+https://github.com/google/benchmark.git'
'submodule-protobuf'::'git+https://github.com/google/protobuf.git'
- 'submodule-android-cmake'::'git+https://github.com/taka-no-me/android-cmake.git'
+ 'submodule-android-cmake'::'git+https://github.com/Yangqing/android-cmake.git'
'submodule-ios-cmake'::'git+https://github.com/Yangqing/ios-cmake.git'
'submodule-NNPACK'::'git+https://github.com/Maratyszcza/NNPACK.git'
'submodule-gloo'::'git+https://github.com/facebookincubator/gloo'
@@ -94,11 +94,6 @@ prepare() {
done
unset _submodule
git submodule update
-
- # avoid compile errors with gloo if using '-march=native' in a cpu with AVX2
- # https://github.com/facebookincubator/gloo/issues/43
- cd third_party/gloo
- git checkout 21a5c8ea5e02edca03068790df3d7f7ba4e2d75b
}
pkgver() {