summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHugo Osvaldo Barrera2015-06-09 01:43:32 -0300
committerHugo Osvaldo Barrera2015-06-09 01:43:32 -0300
commitd42e7fb5fb7b00137043f3184b3a4862753e12d7 (patch)
treefce9b7a69e68f13fa188e34f4c0b28f955aafd98 /PKGBUILD
downloadaur-d42e7fb5fb7b00137043f3184b3a4862753e12d7.tar.gz
Initial commit.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9ebd9b9451d1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Hugo Osvaldo Barrera <hugo@barrera.io>
+
+pkgname=caffeine-ng
+pkgver=3.1
+pkgrel=1
+pkgdesc="Status bar application able to temporarily inhibit the screensaver and sleep mode."
+arch=(any)
+url=https://github.com/hobarrera/caffeine-ng
+license=(GPL3)
+depends=(python-gobject python-xdg python-dbus python-docopt python-ewmh gtk3
+ libnotify python-setproctitle)
+optdepends=("libindicator-gtk3: AppIndictor support.")
+conflicts=(caffeine caffeine-bzr caffeine-oneclick caffeine-systray)
+provides=(caffeine caffeine-bzr caffeine-oneclick caffeine-systray)
+replaces=(caffeine-oneclick caffeine-systray)
+options=(!emptydirs !libtool)
+install=$pkgname.install
+source=("$pkgver.tar.gz::https://git.barrera.io/hobarrera/$pkgname/repository/archive.tar.gz?ref=v$pkgver")
+sha256sums=('08f1034895013d99e31ede006543eabeace368378e36a9be4b27b51a3fd80fc0')
+
+build() {
+ cd $pkgname.git
+ python setup.py build
+}
+
+package() {
+ cd $pkgname.git
+ python setup.py install --root="$pkgdir"
+}