summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHugo Osvaldo Barrera2022-07-26 22:24:40 +0200
committerHugo Osvaldo Barrera2022-07-26 22:24:40 +0200
commit6dab3178986153fe354083460b9eb01cf28d7f7c (patch)
treeddb1325c56053ea45aa22f5706e3a26f4b052a75 /PKGBUILD
parentadfbfdb833b2fd12bbbf016d19a4a59ddfeb8302 (diff)
downloadaur-6dab3178986153fe354083460b9eb01cf28d7f7c.tar.gz
Update to use meson as a build system
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 12 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d7930709d0f4..7a040f8f7ce6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=caffeine-ng-git
_pkgname=caffeine-ng
-pkgver=3.5.2.dev121+g47dcc5c
+pkgver=v4.0.2.r5.gc7b1800
pkgrel=1
pkgdesc="Status bar application able to temporarily inhibit the screensaver and sleep mode."
arch=(any)
@@ -17,15 +17,13 @@ depends=(
gtk3
libnotify
python-setproctitle
- python-wheel
python-pulsectl
libindicator-gtk3
+ libappindicator-gtk3
)
makedepends=(
git
- python-setuptools-scm
- python-build
- python-installer
+ meson
)
conflicts=(caffeine caffeine-bzr caffeine-oneclick caffeine-systray)
provides=(caffeine caffeine-bzr caffeine-oneclick caffeine-systray)
@@ -35,15 +33,21 @@ sha256sums=('SKIP')
pkgver() {
cd "$srcdir/$_pkgname"
- python -m setuptools_scm 2> /dev/null
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
cd "$srcdir/$_pkgname"
- python -m build --wheel --no-isolation
+ arch-meson build
+ meson compile -C build
+}
+
+check() {
+ cd "$srcdir/$_pkgname"
+ meson test -C build
}
package() {
cd "$srcdir/$_pkgname"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ meson install -C build --destdir "$pkgdir"
}