summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHugo Osvaldo Barrera2022-04-18 19:12:52 +0200
committerHugo Osvaldo Barrera2022-04-18 19:12:52 +0200
commite1498d554a5d9541cece042de96eb519b9327df0 (patch)
tree2c35bf5dde20c6224059f762d113c6201ac56a1c /PKGBUILD
parent8cfe84fb59ff84eb73ff817d21ae55e2abdd5601 (diff)
downloadaur-e1498d554a5d9541cece042de96eb519b9327df0.tar.gz
Adopt PEP 517 tooling
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 10 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4a571da08a47..03ea7a8fa17a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=caffeine-ng-git
_pkgname=caffeine-ng
-pkgver=3.5.1.post52+g7b193de
+pkgver=3.5.2.dev88+gef22619
pkgrel=1
pkgdesc="Status bar application able to temporarily inhibit the screensaver and sleep mode."
arch=(any)
@@ -21,7 +21,12 @@ depends=(
python-pulsectl
libindicator-gtk3
)
-makedepends=(git python-setuptools-scm)
+makedepends=(
+ git
+ python-setuptools-scm
+ python-build
+ python-installer
+)
conflicts=(caffeine caffeine-bzr caffeine-oneclick caffeine-systray)
provides=(caffeine caffeine-bzr caffeine-oneclick caffeine-systray)
replaces=(caffeine-oneclick caffeine-systray)
@@ -30,15 +35,15 @@ sha256sums=('SKIP')
pkgver() {
cd "$srcdir/$_pkgname"
- python setup.py --version
+ python -m setuptools_scm 2> /dev/null
}
build() {
cd "$srcdir/$_pkgname"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "$srcdir/$_pkgname"
- python setup.py install --root="$pkgdir"
+ python -m installer --destdir="$pkgdir" dist/*.whl
}