summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPatrick Oppenlander2015-06-19 10:01:39 +1000
committerPatrick Oppenlander2015-06-19 10:01:39 +1000
commit1f490e152b4dcecd75e47620a1c333ce7493b971 (patch)
treead762d942bbfab2740e0f708925c19f2d7b7b6f5 /PKGBUILD
downloadaur-1f490e152b4dcecd75e47620a1c333ce7493b971.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..234593c3e55d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Patrick Oppenlander <patrick.oppenlander@gmail.com>
+
+pkgname=cairo-minimal
+pkgver=1.14.2
+pkgrel=1
+pkgdesc="A vector graphics library - build with minimal dependencies"
+arch=(i686 x86_64)
+license=('LGPL' 'MPL')
+url="http://cairographics.org/"
+depends=('libpng' 'sh' 'fontconfig' 'pixman>=0.30.0' 'glib2' 'lzo2' 'gcc-libs')
+provides=('cairo-xcb' 'cairo')
+replaces=('cairo-xcb' 'cairo')
+source=(http://cairographics.org/releases/${pkgname:0:5}-$pkgver.tar.xz)
+
+sha1sums=('c8da68aa66ca0855b5d0ff552766d3e8679e1d24')
+
+build() {
+ cd ${pkgname:0:5}-$pkgver
+
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --disable-static \
+ --enable-tee \
+ --disable-gl \
+ --disable-egl \
+ --enable-svg \
+ --enable-ps \
+ --enable-pdf \
+ --enable-gobject
+ make
+}
+
+package() {
+ cd ${pkgname:0:5}-$pkgver
+ make DESTDIR="$pkgdir" install
+}