summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorgxb1522020-04-16 19:09:41 +0800
committergxb1522020-04-16 19:09:41 +0800
commit3f75586dd046e8a3b582f3567dd3a230144a1ea7 (patch)
tree26670967485b1ad3cc7d3d012c3e29cdd3640711 /PKGBUILD
parent8fd6f5cc045d1aa4209dda76fc4e4bbc3725f982 (diff)
downloadaur-3f75586dd046e8a3b582f3567dd3a230144a1ea7.tar.gz
nothing
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8f5dcdc3e27f..cb83cda28c9f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,24 +7,25 @@ pkgrel=1
pkgdesc="CAJViewer for Linux"
arch=("x86_64")
url="http://cajviewer.cnki.net"
-noextract=("CAJViewer-x86_64-libc-2.24.AppImage")
+_pkgname="CAJViewer-x86_64-libc-2.24.AppImage"
+noextract=(${_pkgname})
options=("!strip")
provides=('cajviewer')
-_pkgname="CAJViewer-x86_64-libc-2.24.AppImage"
+conflicts=('cajviewer')
source=("http://viewer.d.cnki.net/CAJViewer-x86_64-libc-2.24.AppImage")
sha256sums=("2ee4ca35cc031ebdc413bcb46d63bb1b7f720c7a9db45641e25614f589f4933f")
prepare() {
cd "${srcdir}"
- chmod a+x "${_pkgname}"
+ chmod a+x ${_pkgname}
${srcdir}/${_pkgname} --appimage-extract
- sed -i "s+Exec=cajviewer+Exec=env DESKTOPINTEGRATION=yes ${_installdir}/${_pkgname} %U+" "squashfs-root/cajviewer.desktop"
+ sed -i "s+Exec=cajviewer+Exec=${_installdir}/${_pkgname} %U+" "squashfs-root/cajviewer.desktop"
find "squashfs-root/usr/share/icons/hicolor" -type d -exec chmod 755 {} \;
}
package() {
install -dm755 "${pkgdir}/usr/share/icons"
- install -Dm755 "${_pkgname}" "${pkgdir}/${_installdir}/${_pkgname}"
+ install -Dm755 ${_pkgname} "${pkgdir}/${_installdir}/${_pkgname}"
install -Dm644 "squashfs-root/cajviewer.desktop" "${pkgdir}/usr/share/applications/cajviewer.desktop"
cp -R "squashfs-root/usr/share/icons/hicolor" "${pkgdir}/usr/share/icons"
}