summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorvvxxp82020-12-10 16:56:22 +0800
committervvxxp82020-12-10 16:56:22 +0800
commit95c6bb508308a16cc1dd583516a5a0abd96d9714 (patch)
tree46f5209234c091f55bc0864df7b9b45911901594 /PKGBUILD
parent9ef3f92395c1154bc2a226abdc0a144d9e1d4b84 (diff)
downloadaur-95c6bb508308a16cc1dd583516a5a0abd96d9714.tar.gz
v201021
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 20 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 55b980af26d4..a1312d055d6b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,31 @@
+# Maintainer: vvxxp8 <concatenate[g] the characters[x] in square[b] brackets[1] in[5] order[3] at gmail dot com
+
pkgname=cajviewer-appimage
_installdir=/opt/${pkgname}
-pkgver=1.0.0
+pkgver=201021
pkgrel=1
pkgdesc="CAJViewer for Linux"
arch=("x86_64")
url="http://cajviewer.cnki.net"
-_pkgname="CAJViewer-x86_64-libc-2.24.AppImage"
+_pkgname="CAJViewer-${arch}-buildubuntu1604-${pkgver}.AppImage"
noextract=(${_pkgname})
options=("!strip")
+provides=('cajviewer')
+conflicts=('cajviewer')
+source=("https://download.cnki.net/${_pkgname}")
+sha512sums=("04c702e563587bda4c924fb554f0aef3e63a3dff088b2cecbf21c03723352595b3d0adfe14bedd2c875960dd64c69f5e6c4318684d9bbcd60e7ec5f2fe613bc9")
prepare() {
- msg2 '这是个空包, 啥都没做!!!'
+ cd "${srcdir}"
+ chmod a+x ${_pkgname}
+ ${srcdir}/${_pkgname} --appimage-extract
+ sed -i "s+Exec=cajviewer+Exec=env DESKTOPINTEGRATION=no ${_installdir}/cajviewer.AppImage+" "squashfs-root/cajviewer.desktop"
+ find "squashfs-root/usr/share/icons/hicolor" -type d -exec chmod 755 {} \;
+}
+
+package() {
+ install -dm755 "${pkgdir}/usr/share/icons"
+ install -Dm755 ${_pkgname} "${pkgdir}/${_installdir}/cajviewer.AppImage"
+ install -Dm644 "squashfs-root/cajviewer.desktop" "${pkgdir}/usr/share/applications/cajviewer.desktop"
+ cp -R "squashfs-root/usr/share/icons/hicolor" "${pkgdir}/usr/share/icons"
}