summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorThomas Wucher2015-07-09 11:09:05 +0200
committerThomas Wucher2015-07-09 11:21:55 +0200
commit6db1d184b3086a6baea01f85abe2920e12474440 (patch)
treebaeccc50b4e2d06c8565b8430346585fb8228888 /PKGBUILD
downloadaur-6db1d184b3086a6baea01f85abe2920e12474440.tar.gz
Initial commit, calcelestial 1a7fe12
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6cd23df69b9c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+pkgname=calcelestial
+pkgver=0.3
+pkgrel=1
+pkgdesc="calculates positions, rise and set times of celestial bodies"
+arch=('i686' 'x86_64' 'armv6h' 'armv7h')
+url="http://www.steffenvogel.de/2012/12/23/cron-jobs-fur-sonnenauf-untergang/"
+license=('GPL3')
+depends=('libnova')
+source=("https://github.com/stv0g/${pkgname}/archive/${pkgver}.tar.gz"
+ "disable-geonames.patch")
+md5sums=('SKIP'
+ 'a4bc96095f1096c6357150577650c438')
+conflicts=()
+provides=()
+
+prepare() {
+ cd "${pkgname}-${pkgver}"
+ patch -i ../disable-geonames.patch -p1
+}
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ ./autogen.sh
+ ./configure --prefix=/usr --disable-geonames
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ make DESTDIR="${pkgdir}/" install
+}